Sign up ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I am having a hyper-v issue. Creating a new VM and saving it to a different location. I am trying to save it to a Windows Server 2012 Storage Server (NAS). I keep getting the error about not having permissions. I have shared the folder on the NAS with all the permissions, went into the 2008 R2 Domain controller and established the delegation between the two machines, read most of the articles on the internet concerning this issue….nothing seems to help….any suggestions?

share|improve this question
Give us some details. Screenshots of the share and NTFS permissions of the folder in question. Tell us what user is accessing the folder, too. –  mfinni Aug 8 '13 at 20:07
If it's a hyperV cluster, which is why I'd imagine you'd use a NAS instead of just direct attatched storage, then you need to make sure you mark the VM you're creating to be created as highly available. There's a checkbox for this in the VM settings/creation process and without that being selected, HyperV gets pouty about putting the VM onto shared storage. –  RobM Aug 8 '13 at 20:36

1 Answer 1

I had a similar issue when creating VMs from the fail-over cluster manager. Also came up when trying to export VMs.

Tried the solution here and worked for me.

(Written for 2008 but worked for 2012 as well)

share|improve this answer
Problem solved. Thank you very much! The solution above was the key. The KB2008849 explained that you must use computer objects as well as user permissions. –  bob Aug 12 '13 at 16:47

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.