Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have a few Cisco 1721s and a WIC-4ESW. I was running another companies home router as my cable router, but decided to turn that into a wireless bridge and use my extra Cisco as my router. I recently upgraded my service plan with my provider to go from 8M down to 18M down. After they did what they needed to my cable modem I didn't notice any difference in the speed. My provider has a speed test server on their network to test with so I started testing my speed and I will still getting only 6-8M down at 2:00am.

  • I connected my computer directly to the cable modem and ran the test a few more times and noticed that I was getting about 18M down almost everytime. I put the Cisco back on, back to 6M down. Tried about 3 times.

  • I checked all the interfaces on the Cisco, no errors, or anything unusual. I then used the exact same cables and made my other companies product the router instead of a bridge and ran the tests again... 18M down, three times.

Can anybody tell me why my Cisco is slowing things down so much?

I even tried switching from the old style NAT to NVI, but that seemed even slower...

I also tried to change the MAC address of the outside interface thinking that my provider might be doing QOS on the source address I was getting from DHCP.

Thanks,

Shawn

Cisco IOS Software, C1700 Software (C1700-ADVIPSERVICESK9-M), Version 12.4(25d))
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2010 by Cisco Systems, Inc.
Compiled Wed 18-Aug-10 04:02 by prod_rel_team

ROM: System Bootstrap, Version 12.2(7r)XM2, RELEASE SOFTWARE (fc1)

router uptime is 30 minutes
System returned to ROM by reload at 06:27:19 UTC Fri Aug 9 2013
System image file is "flash:c1700-advipservicesk9-mz.124-25d.bin"


This product contains cryptographic features and is subject to United
States and local country laws governing import, export, transfer and
use. Delivery of Cisco cryptographic products does not imply
third-party authority to import, export, distribute or use encryption.
Importers, exporters, distributors and users are responsible for
compliance with U.S. and local country laws. By using this product you
agree to comply with applicable laws and regulations. If you are unable
to comply with U.S. and local laws, return this product immediately.

A summary of U.S. laws governing Cisco cryptographic products may be found at:
http://www.cisco.com/wwl/export/crypto/tool/stqrg.html

If you require further assistance please contact us by sending email to
export@cisco.com.

Cisco 1721 (MPC860P) processor (revision 0x500) with 118050K/13022K bytes of me.
Processor board ID FOC09421G3V (436675680), with hardware revision 0000
MPC860P processor: part number 5, mask 2
1 Ethernet interface
5 FastEthernet interfaces
32K bytes of NVRAM.
32768K bytes of processor board System flash (Read/Write)

Configuration register is 0x2102

-------------------------------------------------------------------------------

router#sho inventory
NAME: "1721 chassis", DESCR: "1721 chassis, Hw Serial#: 436675680, Hw Revision:"
PID: 1721              , VID: 0x500, SN: FOC09421G3V (436675680)

NAME: "Chassis Slot", DESCR: "1700 Chassis Slot"
PID: 1700 Chassis Slot , VID:    , SN:

NAME: "C1721 Mainboard", DESCR: "C1721 Mainboard"
PID: C1721 Mainboard   , VID: 0x500, SN: FOC09421G3V (436675680)

NAME: "Daughter card slot:0", DESCR: "1700 DaughterCard Slot"
PID: 1700 DaughterCard Slot, VID:    , SN:

NAME: "WAN Interface Card - 4 Port FE Switch", DESCR: "WAN Interface Card - 4 P"
PID: WIC-4ESW=         , VID: 1.0, SN: FOC09144DZ1

NAME: "Ethernet0", DESCR: "PQUICC Ethernet"
PID: PQUICC Ethernet   , VID:    , SN:

NAME: "FastEthernet1", DESCR: "Fast Ethernet"
PID: Fast Ethernet     , VID:    , SN:

NAME: "FastEthernet2", DESCR: "Fast Ethernet"
PID: Fast Ethernet     , VID:    , SN:

NAME: "FastEthernet3", DESCR: "Fast Ethernet"
PID: Fast Ethernet     , VID:    , SN:

NAME: "FastEthernet4", DESCR: "Fast Ethernet"
PID: Fast Ethernet     , VID:    , SN:

NAME: "Daughter card slot:1", DESCR: "1700 DaughterCard Slot"
PID: 1700 DaughterCard Slot, VID:    , SN:

NAME: "FastEthernet0", DESCR: "PQUICC_FEC"
PID: PQUICC_FEC        , VID:    , SN:

--------------------------------------------------------------------------------

version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname router
!
boot-start-marker
boot-end-marker
!
logging buffered 60000 debugging
logging console critical
enable secret 5 xxx
!
aaa new-model
!
aaa authentication login default local
!
aaa session-id common
ip cef
!
ip domain name toad-host.com
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
username xxx
!
ip ssh version 2
!
interface FastEthernet0
mac-address 0004.4b16.8271
ip address dhcp
ip nat outside
ip virtual-reassembly
speed 100
full-duplex
!
interface FastEthernet1
description Inside
switchport access vlan 100
!
interface FastEthernet2
shutdown
!    
interface FastEthernet3
shutdown
!
interface FastEthernet4
shutdown
!
interface Vlan1
no ip address
shutdown    
!
interface Vlan100
ip address 192.168.1.1 255.255.255.0
ip nat inside
ip virtual-reassembly
!
ip forward-protocol nd
!
ip dns server
!
no ip http server
no ip http secure-server
ip nat inside source list 100 interface FastEthernet0 overload
ip nat inside source static tcp 192.168.1.10 22 interface FastEthernet0 22
!
logging trap debugging
logging 192.168.1.10
access-list 10 permit 192.168.1.0 0.0.0.255 log
access-list 10 deny   any log
access-list 100 permit ip any any
!
control-plane
!
line con 0
 logging synchronous
line aux 0
line vty 0 4
 access-class 10 in
 logging synchronous
 transport input ssh
line vty 5 15
 access-class 10 in
 logging synchronous
 transport input ssh
!
ntp clock-period 17180034
ntp server 192.5.41.41
ntp server 192.5.41.40
end

Edit: In response to Paul Rudnitskiy

router#sho ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
   D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
   N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
   E1 - OSPF external type 1, E2 - OSPF external type 2
   i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
   ia - IS-IS inter area, * - candidate default, U - per-user static route
   o - ODR, P - periodic downloaded static route

Gateway of last resort is 24.49.40.1 to network 0.0.0.0

 172.16.0.0/32 is subnetted, 1 subnets
S       172.16.100.4 [254/0] via 24.49.40.1, FastEthernet0
 24.0.0.0/22 is subnetted, 1 subnets
C       24.49.40.0 is directly connected, FastEthernet0
C    192.168.1.0/24 is directly connected, Vlan100
S*   0.0.0.0/0 [254/0] via 24.49.40.1

During the speed test with my provider's server

CPU utilization for five seconds: 34%/32%; one minute: 7%; five minutes: 4%
 PID Runtime(ms)   Invoked      uSecs   5Sec   1Min   5Min TTY Process
 39       39132       700      55902  0.65%  0.10%  0.06%   0 Per-minute Jobs
163        1804       336       5369  0.40%  0.98%  0.40%   0 DNS Server Input
  9        1512      4110        367  0.24%  0.58%  0.33%   0 ARP Input
162        1908     14331        133  0.16%  0.69%  0.37%   0 DNS Server
 48         828      1873        442  0.16%  0.23%  0.14%   0 IP Input
151          60        53       1132  0.08%  0.01%  0.00%   0 Syslog

Directly after the speed test finished.

CPU utilization for five seconds: 3%/3%; one minute: 8%; five minutes: 5%
 PID Runtime(ms)   Invoked      uSecs   5Sec   1Min   5Min TTY Process
   9        1580      4245        372  0.40%  0.51%  0.33%   0 ARP Input
  48         840      1895        443  0.16%  0.19%  0.14%   0 IP Input
  67          52       753         69  0.08%  0.00%  0.00%   0 IP Background
   1          12        12       1000  0.00%  0.00%  0.00%   0 Chunk Manager
   2         104      8376         12  0.00%  0.00%  0.00%   0 Load Meter
   3           4       412          9  0.00%  0.00%  0.00%   0 Spanning Tree
   4           4         1       4000  0.00%  0.00%  0.00%   0 EDDRI_MAIN
   5      102004      6382      15983  0.00%  0.22%  0.23%   0 Check heaps
share|improve this question
    
Please share your "show ip route" command output. Also please check cpu loads. –  Paul Rudnitskiy Aug 9 '13 at 10:23
    
I've added that information as an edit, thanks. –  btk_ Aug 9 '13 at 18:17

2 Answers 2

According to http://www.cisco.com/web/partners/downloads/765/tools/quickreference/routerperformance.pdf

The 1721's peak throughput capability is 12,000 packets per second and packets are at most 1,500 bytes.

This means that under ideal, perfect conditions, the 1721 maxes out at 17Mbps. NAT, and small packets approximately halves that. The data sheet says that CEF performance is 6.14Mbit/s.

The 1721 was intended to handle data at T1 speeds.

share|improve this answer
    
Thank you so much for this answer and link. For some reason I hadn't thought about looking that up. I guess I just thought a Cisco would out route an Airport Extreme... –  btk_ Aug 9 '13 at 21:57
    
There's a math error in this answer. 12,000 packets per second at 1,500 bytes each is 17MBps, not 17Mbps, which breaks the logic of the answer. I believe it is still correct that the 1721 is overwhelmed, but I'm not sure why -- likely because NAT is so expensive for the 1721. –  David Schwartz Aug 10 '13 at 20:51
    
OK now I'm confused after I looked at the math. 1500 bytes x 8 = 12000 bits per packet. 12000 bits per packet x 12000 packets per second = 144,000,000 bits per second. So that is either 144 Mbps or 140.6 Mbps. How did you come to 17 MBps? –  btk_ Aug 11 '13 at 1:45
    
I am going to run a test with two machines on either side of the router with iperf. Its kind o moot now since I just bought a 3745, but I would still like to know. –  btk_ Aug 11 '13 at 1:57
    
I wouldn't worry about the maths, look at the rated throughput on the Router Performance pdf (linked), especially as that's measured with 64b packets (as you rarely get 100% full packets). –  Tom O'Connor Aug 11 '13 at 19:52
up vote 1 down vote accepted

OK, I hooked up two machines: one to the on board FE port and one to a port on the WIC-4ESW.

  • I disabled all firewalls on the hosts. Setup NAT without the NVI between the two interfaces.
  • I ran iPerf 3 times and averaged 9.31 Mbps.
  • I turned off NAT, tried again, and averaged about the same.

I then looked at the show version again and noticed.

1 Ethernet interface
5 FastEthernet interfaces

Since there is only one on board FE and the WIC-4ESW has four I was wondering where the other Ethernet interface came from.

After some research, turns on that any routing between the onboard FE and WIC or inter-vlan routing on the WIC is limited to 10Mbps because the extra Ethernet interface is the link to the CPU. Not mentioned in the router performance guide, but buried deep in the configuration guides on Cisco's site.

So yeah... The 1721 will always be limited (routing wise) to that 10Mbps (Full Duplex) link to the CPU.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.