Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Problem

The Ethernet virtual device of my DomU doesn't seems to load and I can't explain why.

Context

Dom0 Info

Dom0 : Debian Wheezy with Xen

uname -r : 3.2.0-4-amd64

Dom0 dmesg

[11:55]root@Dopamine2:~[0]# dmesg | grep Network
[   11.550947] Intel(R) Gigabit Ethernet Network Driver - version 3.2.10-k
[   11.627242] igb 0000:03:00.0: Intel(R) Gigabit Ethernet Network Connection
[   11.705513] igb 0000:03:00.1: Intel(R) Gigabit Ethernet Network Connection

Dom0 lspci

03:00.0 Ethernet controller: Intel Corporation I350 Gigabit Network Connection (rev 01)
03:00.1 Ethernet controller: Intel Corporation I350 Gigabit Network Connection (rev 01)

One Working DomU

I have 1 x fresh DomU (wheezy), installed with "xen-create-image", working perfectly. When I do a dmesg on this DomU, we can see inside : "Initialising Xen virtual ethernet driver"

Failing DomU (the problem)

But another existing DomU (that I want to migrate from an old Dom0 to the new one), also a Debian wheezy, seems to be not working. Network is not loaded :

/etc/init.d/networking restart
[warn] Running /etc/init.d/networking restart is deprecated because it may not re-enable some interfaces ... (warning).
[....] Reconfiguring network interfaces...Cannot find device "eth0"
Failed to bring up eth0.

When I do a dmesg on this failing box, the "Initialising Xen virtual ethernet driver" is NOT inside.

(I don't know what other information I can provide ?)

share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

Maybe you need to load some missing modules in your guest

Try lsmod | grep xen in your working guest and failing guest and compare them. If you see a difference, try to load this module in your Dom0 /etc/initramfs-tools/modules and update the initramfs

I suspect that you should load the xen_netfront module.

Add the missing module

echo xen_netfront >> /etc/initramfs-tools/modules

Update initramfs

cd /tmp
mkinitramfs $(uname -r) -o /tmp/initrd-$(uname -r) 
cp /tmp/initrd-$(uname -r) /boot/initrd-$(uname -r)

This is the file you should load in your /etc/xen/your-guest.cfg

For example ramdisk = '/boot/initrd-3.2.0-4-amd64'

Then shutdown and re-create the failing guest

xm shutdown guest
xm create guest.cfg

And check the result.

share|improve this answer
    
Works perfectly, it was this. Thanks so much. –  Anthony Aug 9 '13 at 13:15
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.