Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am having a problem with the time on my VPS hosted at Rackspace. Its running Red Hat Enterprise Linux 5.4. Date commands gives a time which is 11 minutes ahead of the actual time.

I am running ntpd and my /etc/ntp.conf is as per the 2nd option given here

I also modified /etc/sysconfig/ntpd and changed SYNC_HWCLOCK=yes and rebooted the server.

None of this has helped so far. I contacted Rackspace and their answer was the time on the main host is OK.

Output of ntpq -p is:

ntpq -p output

I would appreciate any assistance on this.

share|improve this question

2 Answers 2

The instances where I've seen this is when using a xen vm machine, who has a hypervisor with a clock that is not in sync.

No matter what you do, by default, the xen guest will sync its time with the dom0 (hypervisor), and that is why neither NTP nor setting the time "by force" works without setting:

xen.independent_wallclock = 1  

Maybe your hosting provides hypervisor you happen to be running on does not use NTP, or is syncing with a bad time source...

share|improve this answer

Known problem. It is like that on VPS. Run a NTP daemon that regularly (every 30 seconds for examlple) resyncs the clock.

share|improve this answer
    
I have had ntp running for a few days but so far it has not helped, I also ran ntpdate which I am assuming should have sync'ed the time. Is there anything I can do force the time to sync? –  Gulam Aug 10 '13 at 10:31
    
Sorry, I Do not do linux. I sugest to read the documentation of open a PROPER question for that (i.e. how to configure NTP correct). –  TomTom Aug 10 '13 at 10:33
1  
ok, i fixed the problem by sysctl -e xen.independent_wallclock = 1 and adding this line to /etc/sysctl.conf –  Gulam Aug 10 '13 at 13:39

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.