Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a company website which uses Windows Authentication. The site runs on Windows Server 2008 R2, IIS 7.

When we try to access it from mobile, we get mixed results - some browsers do succeed to login, some do not even show the login window, and some do show the login window but when I enter the credentials they just show the window once more endlessly.

The breakdown of the options is like that:

HTC One              Android 4.22     Native Browser    SUCCESS 
Motorola Xoom 1      Andorid 4.0.4    Native Browser    repetitive login
Motorola Xoom 1      Andorid 4.0.4    Firefox           repetitive login
Motorola Razr M      Android 2.3.6    Firefox           repetitive login
Morotola Droid Pro   Android 2.3.4    Native Browser    error 401, no login screen
Morotola Droid Pro   Android 2.3.4    Firefox           SUCCESS (surprisingly...)
Samsung S I mini     someting old     Native Browser    error 401, no login screen
Samsung S I mini     someting old     Firefox           repetitive login

I've seen posts saying FIrefox would fix the NTLM login issue on Androids < 4.0, but I see it's not the case on the majority of Androids and also that there is a problem also on Android 4.0.4.

On iOS and WP8 the login succeeds.

My questions are:

  • Why is it so?
  • What can be done to use Windows Authentication reliably on mobile?

Thanks.

share|improve this question
    
Are you always providing your credentials as DOMAIN\username when logging in? I have seen different browsers behave differently when only the username is supplied. –  Jeremy Lyons Aug 15 '13 at 0:05
    
Yes, it works! Thank you man! Write an answer I'll mark it as solved :) –  alex440 Aug 15 '13 at 8:58
    
No problem! I copied this into an answer. –  Jeremy Lyons Aug 16 '13 at 19:37

1 Answer 1

up vote 0 down vote accepted

Are you always providing your credentials as DOMAIN\username when logging in? I have seen different browsers behave differently when only the username is supplied.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.