Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am very confused by this. I will give a brief explanation of what has happened and where it went wrong, hopefully someone will know the answer.

The server is hosted on a virtual machine, which I am able to connect to via SSH. I am trying to set up single sign-on for a wiki on there. I started by forcing the wiki to use https.

Everything was working fine at this point, and I started configuring shibboleth (for SSO). To include the shibboleth module I included a few lines in the apache2.conf file, after which I could no longer navigate to the wiki in my browser. Yesterday, I tried backtracking and found that it was the load module mod_shib... line that was causing the problem - commenting out the line immediately allowed me to navigate to the wiki. Now today, even after removing the line I cannot navigate to the wiki at all. I made some other minor changes as well, and so I tried restoring all of the backups to see if it was something I did, but still nothing.

I should also mention, for a while https was not set up correctly as I'd forgotten to include the trust chain file. Using openssl I found that I was getting return code 21, and so I added the chain file and then got return code 0 (all working well). After restarting apache it was all still working though, I could still navigate to the wiki perfectly. I just thought I would mention this because it was the last significant change I made that I can think of.

If anyone could figure this out, or give me any advice on how I can figure it out, I'd be very grateful.

Edit: Oh, I almost forgot. After using openssl s_client -CApath /... -connect server:443 yesterday and getting return code 0, everything was working fine. Today (not having changed anything significant that I can think of) using the same command I am simple getting CONNECTED (00000003), and then nothing. What is up with that?

share|improve this question
    
Anything useful in apache's error log? –  Flup Aug 14 '13 at 13:31
    
Wow, well in the error log there are thousands and thousands of lines of "mod_shib failed to load configuration: XML error(s) during parsing", these errors have been occurring literally every second (sometimes multiple times per second) since yesterday! I have no idea what could have caused this! –  user185593 Aug 14 '13 at 13:54
    
The weirdest part is, the error log keeps churning out errors to do with loading the mod_shib module, but I commented it out ages ago when I thought that was causing it (and have since removed it entirely)! How is this still causing a problem??? –  user185593 Aug 14 '13 at 15:20
1  
Have you restarted apache since then? –  Flup Aug 14 '13 at 15:21
    
Yes, I restart apache practically every time I make a change, which is why I am so confused by the errors - undoing the changes made since it went wrong has done nothing to solve the problem. –  user185593 Aug 15 '13 at 9:48

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.