Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

here is my config for eth0

/etc/sysconfig/network/ifcfg-eth0

BOOTPROTO='static'
BROADCAST=''
ETHTOOL_OPTIONS=''
IPADDR='5.1.0.2/24'
IPADDR_V6='5:1:0:1::2/64'
MTU=''
NAME='82540EM Gigabit Ethernet Controller'
NETMASK=''
NETWORK=''
REMOTE_IPADDR=''
STARTMODE='auto'
USERCONTROL='no'

suse64:/etc/sysconfig/network # ifconfig 
eth0      Link encap:Ethernet  HWaddr 02:00:20:EE:6B:01  
          inet addr:5.1.0.2  Bcast:5.1.0.255  Mask:255.255.255.0
          inet6 addr: 5:1:0:1::2/64 Scope:Global
          inet6 addr: fe80::20ff:feee:6b01/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:96871 errors:0 dropped:0 overruns:0 frame:0
          TX packets:76100 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:9308862 (8.8 Mb)  TX bytes:6519068 (6.2 Mb)

after a ifconfig eth0 down, then ifconfig eth0 up, the ipv6 address is not brought up. I have to to do a rcnetwork restart to get it up.

suse64:/etc/sysconfig/network # ifconfig 
eth0      Link encap:Ethernet  HWaddr 02:00:20:EE:6B:01  
          inet addr:5.1.0.2  Bcast:5.1.0.255  Mask:255.255.255.0
          inet6 addr: fe80::20ff:feee:6b01/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:96846 errors:0 dropped:0 overruns:0 frame:0
          TX packets:76066 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:9306424 (8.8 Mb)  TX bytes:6516032 (6.2 Mb)

Why and how can I bring the v6 stack up?

share|improve this question
    
possible duplicate of Changing ipv6 netmask and gateway on running interface –  dawud Aug 15 '13 at 7:41
add comment

2 Answers 2

Try to use inet6 parameter:

ifconfig eth0 inet6 up

But ifconfig is obsolete. The ip command has more features incl. VLANs (802.1Q) and works better.

ip link set dev eth0 down
ip link set dev eth0 up
ip address show

Explicitly for IPv6 protocol:

ip -6 link set dev eth0 down
ip -6 link set dev eth0 up
ip ad sh
ip -6 ad sh

Maybe the IPv6 is not correctly enabled. Start yast as a su or sudo, then follow these menu items:

--> Network Devices

--> Network Settings

--> Alt+G (Global options)

--> Alt+E (Enable IPv6) in "IPv6 Protocol Settings" section The checkbox must be checked on.

--> OK

reboot

share|improve this answer
add comment

ifup / ifdown will read the interface files

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.