Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm running Debian Wheezy with Gnome-Shell. My current network interface configuration is this:

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
allow-hotplug eth0
iface eth0 inet dhcp

# Bridge setup
# allow-hotplug br0
auto br0 
iface br0 inet static
  address 192.168.0.1
  netmask 255.255.255.0
  bridge_ports none
  bridge_stp off 
  bridge_fd 0
  bridge_maxwait 0

I'm using br0 for virtualisation.

My problem is now that I'm losing the support of Network-Manager for eth0. So I can't use the OpenVPN plugin anymore to quickly connect to my VPN.

Has anyone done such a setup and knows how to configure this proper?

share|improve this question

1 Answer 1

A couple of things,

  1. you didn't bind your bridge to a device
  2. Your still attempting to use you Ethernet device normally

try this: -

# vim /etc/network/interfaces

#The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
auto eth0
iface eth0 inet manual      # set pass through and use br0 for networking

# Bridge setup
allow-hotplug br0
auto br0 
iface br0 inet static
  address 192.168.0.1
  netmask 255.255.255.0
  network 192.168.0.0
  broadcast 192.168.0.255
  gateway 192.168.0.254    # make sure this gateway address is correct
  bridge_ports eth0        # bind to device here
  bridge_stp off 
  bridge_fd 0
  bridge_maxwait 0
share|improve this answer
    
That's true. I forgot to mention that I would still like to be able to run dhcp on my eth0. It's a laptop and it would be pain if I go into another office and has to configure manually eth0 –  Denny Crane Aug 16 '13 at 9:12
    
Thats fine, you can do this by setting br0 to be 'dhcp' and remark out address, netmask, network, broadcast and gateway. to run bridge you will need to leave eth0 as a pass through (bridged device) and usebr0 as your active network device. –  AngryWombat Aug 19 '13 at 6:04
    
I just noticed i had "allow-hotplug br0" as remarked out, now fixed. –  AngryWombat Aug 19 '13 at 6:07

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.