Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

OS: Centos 6.4 OpenLDAP: 2.4 Mac: 10.8.3 through 10.8.4

I have an OpenLDAP server and I'm able to have users authenticate, however, for some reason even though I've changed the Mappings of NFSDirectory to apple-home-userDirectory and pointed it to the correct /Volumes/Users/ it will not create their home directory.

Things I've tried;

I tried commenting out /etc/auto_master and it did not work.

I tried using #/Users/$uid as the mapping, which, did work -- because it simply tells it to ignore the LDAP Home Directory attribute, but I noticed that the resulting behavior was quirky -- as in, if I went to System Preferences > Users & Groups, I was unable to see anything.

Is there a way, like with AD, that you can force it to create a local directory?

I figured this applied as a server question as well, since I have to make changes in both places. I mean, it seems like there is plenty on OpenLDAP + NFS, hardly anything on Open LDAP + Local Directories.

share|improve this question
    
I was only ever able to get #/Users/$uid mapping to work. So, it was not ideal. –  Ethabelle Nov 14 '13 at 15:11
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.