Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am setting up AfterLogic Webmail Lite, which requires PHP with session support. It says that session support is not enabled, but I find this quite strange, since session.save_handler is defined:

session.save_handler = files

I tried setting this to /tmp, but that didn't work either. I installed PHP from the Arch repositories (not AUR). What am I doing wrong?

share|improve this question

1 Answer 1

up vote 0 down vote accepted

Try running php -i (or executing phpinfo() in a script) and check the following :

  • is the session extension loaded ? (running php -m|grep session or executing function_exists("session_start") will also answer to this question)
  • is session.auto_start enabled ?
  • is session.save_path existing and writeable by the server process ?
  • what is the software doing to be able to tell that session support is not enabled ?
share|improve this answer
    
function_exists("session_start") returns true, and php -m | grep session returns 'session'. This is really weird. –  Ian Aug 15 '13 at 20:01
    
Then either the software is expecting session.auto_start to be enabled, or its check is wrong (finding out how the software is checking this might help) –  user68497 Aug 15 '13 at 20:03
    
Its worked in other places. And session.auto_start is set to 1. –  Ian Aug 15 '13 at 20:06
    
Well, it seems that clicking 'Retry' instead of refreshing the page worked. Wow. Sorry for wasting your time. –  Ian Aug 15 '13 at 20:09

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.