Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a terminal server running Windows Server 2008 R2 Standard and there is strange issue that I cannot connect to the server via RDP when I try to do this for the first time, but after first attempt fails, and I try one more time - session can be established and runs smoothly.

There were errors in event viewer like these:

EventID 56 description:

The Terminal Server security layer detected an error in the protocol stream and has disconnected the client. Client IP: www.xxx.yyy.zzz 

EventID 50 description:

The RDP protocol component X.224 detected an error in the protocol stream and has disconnected the client.

which were fixed by disabling some of the advanced features for TCP, described here.

The server is virtual vmware server and not joined to the domain. Has anybody experienced something like this? Any ideas what maybe wrong?

UPD1: I also tried to change RDP-Tcp settings in Remote Desktop Session Host Configuration console on Network Adapters tab specifying exact adapter to use, but this had no effect.

share|improve this question

3 Answers 3

up vote 2 down vote accepted

Finally, I've been able to resolve this after a couple of days.

This is what have been done to fix it:

Step I:

Added a new DWORD key named DisableTaskOffload with a value of 1 to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters

Step II:

Changed IPv4 Checksum Offload for PROD NIC in Advanced Settings.

After these changes, no more issues with RDP not been connected at first attempt or performance issues.

enter image description here

share|improve this answer

It sounds like the certificate might be corrupt on the server:

http://blogs.msdn.com/b/rds/archive/2011/01/10/how-to-resolve-the-issue-remote-desktop-disconnected-or-unable-to-connect-to-remote-desktop-terminal-server.aspx

You might have to remove the X509 Certificate registry keys and then restart the computer, then reactivate the Terminal Services Licensing server. Information on how to do that can be found here:

http://support.microsoft.com/kb/2477176

share|improve this answer

Please refer the following steps:

  1. Whether you installed all the updates in the client computer and TS server.

  2. Make sure you have installed the latest version of the Remote Desktop Connection in client computer or thin client. The Remote Desktop Connection 7.0 client update for Remote Desktop Services (RDS): http://support.microsoft.com/kb/969084/en-us

  3. Please update the client and TS server's NIC driver to the latest version. Try to change client to automatically obtain IP address to see whether the issue still exists.

  4. Please check whether too many users connect to the TS server and the performance loading is too heavy.

  5. Changing the remote desktop setting on the target machine to allow connections from computer running any version of Remote Desktop (less secure) to see whether the issue still exists.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.