Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have an nfsv4 server and client (both RedHat 6) configured with the method set to nsswitch, and the same domain set on both client and server in /etc/idmapd.conf. On the client I get nobody:nobody ownerships and the following message in /var/log/messages for each user:

nfsidmap[632]: nss_getpwnam: name 'bob' not found in domain 'mydomain'

Now the 'bob' account is not on the client system but on the server only, so the client must be getting it through rpcidmapd to show in the log message.

How do I get the proper ownerships to show up and not default back to nobody:nobody?

share|improve this question
add comment

1 Answer

you need user 'bob' on the client and server. You may enforce server to send numeric IDs by

# echo "options nfs nfs4_disable_idmapping=1" >> /etc/modprobe.d/nfs.conf
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.