Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I've bought a new VPS and I'm not a linux geek. I've already installed LEMP stack on CentOS 6. I just tried to install Xcache on my VPS. I've used the below command to install Xcache but it shows an error.

Command I used to install Xcache

yum install php-xcache xcache-admin

And the error I've got:

Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * base: mirror.san.fastserv.com
 * epel: mirrors.kernel.org
 * extras: mirror.pac-12.org
 * updates: mirrors.easynews.com
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package php-xcache.x86_64 0:3.0.2-1.el6 will be installed
--> Processing Dependency: php(zend-abi) = 20090626 for package: php-xcache-3.0.2-1.el6.x86_64
--> Processing Dependency: php(api) = 20090626 for package: php-xcache-3.0.2-1.el6.x86_64
---> Package xcache-admin.noarch 0:3.0.2-1.el6 will be installed
--> Processing Dependency: mod_php for package: xcache-admin-3.0.2-1.el6.noarch
--> Processing Dependency: httpd for package: xcache-admin-3.0.2-1.el6.noarch
--> Running transaction check
---> Package httpd.x86_64 0:2.2.15-29.el6.centos will be installed
---> Package php.x86_64 0:5.3.3-23.el6_4 will be installed
--> Processing Dependency: php-common(x86-64) = 5.3.3-23.el6_4 for package: php-5.3.3-23.el6_4.x86_64
--> Processing Dependency: php-cli(x86-64) = 5.3.3-23.el6_4 for package: php-5.3.3-23.el6_4.x86_64
---> Package php-xcache.x86_64 0:3.0.2-1.el6 will be installed
--> Processing Dependency: php(zend-abi) = 20090626 for package: php-xcache-3.0.2-1.el6.x86_64
--> Processing Dependency: php(api) = 20090626 for package: php-xcache-3.0.2-1.el6.x86_64
--> Running transaction check
---> Package php.x86_64 0:5.3.3-23.el6_4 will be installed
--> Processing Dependency: php-common(x86-64) = 5.3.3-23.el6_4 for package: php-5.3.3-23.el6_4.x86_64
---> Package php-cli.x86_64 0:5.3.3-23.el6_4 will be installed
--> Processing Dependency: php-common(x86-64) = 5.3.3-23.el6_4 for package: php-cli-5.3.3-23.el6_4.x86_64
---> Package php-xcache.x86_64 0:3.0.2-1.el6 will be installed
--> Processing Dependency: php(zend-abi) = 20090626 for package: php-xcache-3.0.2-1.el6.x86_64
--> Processing Dependency: php(api) = 20090626 for package: php-xcache-3.0.2-1.el6.x86_64
--> Finished Dependency Resolution
Error: Package: php-xcache-3.0.2-1.el6.x86_64 (epel)
           Requires: php(api) = 20090626
           Installed: php-common-5.4.17-2.el6.remi.x86_64 (@remi)
               php(api) = 20100412-x86-64
           Available: php-common-5.3.3-22.el6.x86_64 (base)
               php(api) = 20090626
           Available: php-common-5.3.3-23.el6_4.x86_64 (updates)
               php(api) = 20090626
Error: Package: php-xcache-3.0.2-1.el6.x86_64 (epel)
           Requires: php(zend-abi) = 20090626
           Installed: php-common-5.4.17-2.el6.remi.x86_64 (@remi)
               php(zend-abi) = 20100525-x86-64
           Available: php-common-5.3.3-22.el6.x86_64 (base)
               php(zend-abi) = 20090626
           Available: php-common-5.3.3-23.el6_4.x86_64 (updates)
               php(zend-abi) = 20090626
Error: Package: php-cli-5.3.3-23.el6_4.x86_64 (updates)
           Requires: php-common(x86-64) = 5.3.3-23.el6_4
           Installed: php-common-5.4.17-2.el6.remi.x86_64 (@remi)
               php-common(x86-64) = 5.4.17-2.el6.remi
           Available: php-common-5.3.3-22.el6.x86_64 (base)
               php-common(x86-64) = 5.3.3-22.el6
           Available: php-common-5.3.3-23.el6_4.x86_64 (updates)
               php-common(x86-64) = 5.3.3-23.el6_4
Error: Package: php-5.3.3-23.el6_4.x86_64 (updates)
           Requires: php-common(x86-64) = 5.3.3-23.el6_4
           Installed: php-common-5.4.17-2.el6.remi.x86_64 (@remi)
               php-common(x86-64) = 5.4.17-2.el6.remi
           Available: php-common-5.3.3-22.el6.x86_64 (base)
               php-common(x86-64) = 5.3.3-22.el6
           Available: php-common-5.3.3-23.el6_4.x86_64 (updates)
               php-common(x86-64) = 5.3.3-23.el6_4
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Please help me how to install the Xcache on my VPS.

share|improve this question

2 Answers 2

I think the error message is pretty clear:

Error: Package: php-xcache-3.0.2-1.el6.x86_64 (epel)
           Requires: php(api) = 20090626
           Installed: php-common-5.4.17-2.el6.remi.x86_64 (@remi)
               php(api) = 20100412-x86-64

Since you have used the Remi repository to install php-5.4.17-2.el6.remi.x86_64, you should be installing his php-xcache-3.0.3-1.el6.remi.x86_64 package, and not EPEL's, which, as the error message explains, depends on a lower PHP version.

share|improve this answer
    
Will you please tell me what to do now? How to install this REMI package? –  Daman Aug 18 '13 at 12:31
    
How did you install the PHP package in the first place? –  dawud Aug 18 '13 at 12:42
    
Problem Solved... Thanks everyone –  Daman Aug 18 '13 at 12:43
2  
@Daman If this answer helped you solve the problem, please mark it as solved by clicking the check mark next to it. Otherwise please post your own answer and let the world know what you did. –  Michael Hampton Aug 18 '13 at 13:08

Problem Solved

My Problem: I was getting an error while configuring my new VPS. I found that I was trying to install Xcache using EPEL's repo on my VPS. I now installed Xcache using RPM's repository. The whole problem was caused because I had used RPM's repository to install php-5.4.17-2.el6.remi.x86_64. Since I used RPM's repo to install php, I need to do the same to install the Xcache.

Below the code that I used to install Xcache in My CentOS powered VPS

rpm -Uvh http://rpms.famillecollet.com/enterprise/6/remi/x86_64/php-xcache-3.0.3-1.el6.remi.x86_64.rpm

I got the following response from the command line:

Preparing...                ########################################### [100%]   
1:php-xcache-3.0.3-1.el6.remi.x86_64    ########################################### [100%]

Finally, It is working now..

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.