Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am running CentOS 6.3 and I need to install mb-string for PHP. When I attempt to do this I get the following:

[root@pixelark popups]# yum install php-mbstring
Loaded plugins: fastestmirror, security
Loading mirror speeds from cached hostfile
 * Webmin:
 * base:
 * epel:
 * extras:
 * updates:
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package php-mbstring.x86_64 0:5.3.3-23.el6_4 will be installed
--> Processing Dependency: php-common(x86-64) = 5.3.3-23.el6_4 for package: php-mbstring-5.3.3-23.el6_4.x86_64
--> Finished Dependency Resolution
Error: Package: php-mbstring-5.3.3-23.el6_4.x86_64 (updates)
       Requires: php-common(x86-64) = 5.3.3-23.el6_4
       Installed: php-common-5.3.15-1.el6.remi.x86_64 (@remi)
           php-common(x86-64) = 5.3.15-1.el6.remi
       Available: php-common-5.3.3-22.el6.x86_64 (base)
           php-common(x86-64) = 5.3.3-22.el6
       Available: php-common-5.3.3-23.el6_4.x86_64 (updates)
           php-common(x86-64) = 5.3.3-23.el6_4
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

I have done a

yum update

and it is still showing. I have tried updating php in a similar fashion and it says that there are no updates. I do not know what direction I should be going. Should I be trying the two suggestions on the bottom

 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

I dont want to break anything.

share|improve this question
up vote 0 down vote accepted

You are using RPM's from Remi Collet's repository.

Do exactly one of the following:

  1. Uninstall remi's rpm's (can be listed with rpm -qa|grep remi) and install packages with same name (I recommend this, because of this)

  2. Install php-mbstring from remi's repo (yum install php-mbstring --enablerepo=remi should work by default)

share|improve this answer
Will this effect any data when I remove? For example I have this package installed: 'mysql-server-5.5.27-1.el6.remi.x86_64'. If I remove the package, will it remove the MySQL database data? – SpecialK777 Aug 19 '13 at 0:49
no, it wont, but service will be interrupted. you can leave mysql packages as they are, remove only php-related packages. i've never faced any problems with mysql from remi, but php is really problematic. – GioMac Aug 19 '13 at 0:57
I ignored the mysql packages and I followed the instructions above. Worked great. Thank you. For verbose clarity, I used 'yum remove' to uninstall and 'yum install' to install the new packages. – SpecialK777 Aug 19 '13 at 1:02
you're welcome, nice to hear that – GioMac Aug 19 '13 at 1:04
For the record: In five years I have never seen a problem with remi's PHP packages that wasn't a problem with the code itself (rather than the packaging). Rather, remi's packages are very high quality - and he also packages PHP for RHEL! – Michael Hampton Apr 28 '15 at 5:14

You installed PHP from the remi repository, but you disabled the repository. So yum can't install additional packages from it.

To resolve the problem, re-enable the remi repository.

yum-config-manager --enable remi
share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.