Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Everytime I restart my windows guest machine, it resets the date/time to the host date/time.

How can I change it permanently?

UPDATE: Time sync is already disabled in VMware tools

share|improve this question

closed as off-topic by Sven Apr 1 at 10:22

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions on Server Fault must be about managing information technology systems in a business environment. Home and end-user computing questions may be asked on Super User, and questions about development, testing and development tools may be asked on Stack Overflow." – Sven
If this question can be reworded to fit the rules in the help center, please edit the question.

    
    
Can't you just change the timezone? –  Christopher Perrin Mar 31 at 11:41

7 Answers 7

up vote 1 down vote accepted

I had the same issue.

No matter what I tried in the .VMX file or options to set, it always seems to sync the time.

To solve it, I booted in to safe mode and actually disabled the VMware tools service. I cannot remember now if it was the whole tools or if there was just one that was for time sync.

Then edited the time.

This worked and survived a reboot.

share|improve this answer

It turns out it was the windows synchronization service. I disabled automatic time update with the time servers and now it stays changed.

UPDATE: Turns out I was wrong, it DID change back after a while. Disabling VMware service does work!

share|improve this answer

Base on your VMware Workstation version you have to use "0" or "false". For Vmware Workstation 10 its working with these settings:

tools.syncTime = "FALSE"
time.synchronize.continue = "FALSE"
time.synchronize.restore = "FALSE"
time.synchronize.resume.disk = "FALSE"
time.synchronize.shrink = "FALSE"
time.synchronize.tools.startup = "FALSE"
time.synchronize.tools.enable = "FALSE"
time.synchronize.resume.host = "FALSE"

You can use also rtc.startTime = "1416441600" to let the machine start with specific date and time - in this example its 20.11.2014. That number are seconds starting from 1.1.1970

Info from: http://kb.vmware.com/kb/1189

share|improve this answer
    
Could you explain how this is different and better from the two similar answers from '10 and '09? –  Esa Jokinen Apr 1 at 10:27
    
These other answers do not work for Vmware Workstation 10. When its set as "0" , its ignored. You have to use "false" instead. –  Mico_xyz Apr 2 at 10:13

Assuming you have the VMware tools installed in the guest, you might try

tools.syncTime = "FALSE"

in your .vmx file.

A related question.

share|improve this answer
    
It's already in the file (by default) –  John Spaz Aug 12 '09 at 14:29
    
Ah, I see. You may be out of luck. I suspect VMware is setting the emulated hardware clock based on your host clock when it starts the VM. –  retracile Aug 12 '09 at 14:33

Maybe you guest windows virtual machine is joined to the same domain as your host machine and syncing to the server who has the PDC emulator role.

share|improve this answer

You should not have to disable the VMWare service, it is useful for other reasons. Try setting all the time sync related settings:

tools.syncTime = 0
time.synchronize.continue = 0
time.synchronize.restore = 0
time.synchronize.resume.disk = 0
time.synchronize.shrink = 0
time.synchronize.tools.startup = 0

I was experiencing the same problem you are seeing, and this fixed it for me.

share|improve this answer

Actually the .VMX didn't contain any of these parameters except tool.syncTime = "False". Just try to edit/add these parameters to the .VMX file
tools.syncTime = 0
time.synchronize.continue = 0
time.synchronize.restore = 0
time.synchronize.resume.disk = 0
time.synchronize.shrink = 0
time.synchronize.tools.startup = 0

After setting up a desired time in guest OS and after reboot, it came up properly with the desired time.

Thanks guys.

share|improve this answer