Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a Subversion Server running as a resident service on a Windows XP Pro machine. That service needs to access a secure network fileshare, so I used the Services->Properties->Log On tab to tell the service to run as a user who has access to the target fileshare. That works out fine until the machine restarts, when the service fails to autostart.

I am able to start it manually by logging in, going back to that Services->Properties->Log On tab and reconfiming the explicit credentials.

  1. Do I have to manually start this service under alternate credentials every time the machine reboots?
  2. Is there something else I can do to make sure that my Subversion server service autostarts with proper access to authenticate against this network share?
share|improve this question

You have the service set to 'Automatic' in services.msc, right?

share|improve this answer
yes, the service is set to Automatic; my guess was that some security policy might be disallowing the service to automatically start with cached credentials... – David Alpert Aug 13 '09 at 11:55
You could put 'net start serviceshortname' in one of your startup scripts. – tsilb Aug 13 '09 at 16:30

Can you see any error messages in the event viewer when your service is trying to start up (under Application, System, or Security)?

share|improve this answer

Make the service dependent on some other networking service. So it won't start before there is network access.

something like:

sc config YourService depend= rpcss
share|improve this answer

I have a similar problem to this; a service is running quite happily using a service account created in AD. I have to carry out some maintenance on the service, so shut it down, then when I start it up again, it fails with a "The service did not start due to a logon failure" error. Re-entering the credentials in the services.msc snap-in fixes the issue, until the next time.

Is there a way to make the password "stick"?

share|improve this answer

Maybe this requires that the account being used for the service needs to be give the Log On As A Service right? See here.

share|improve this answer
  • While setting up windows service you can edit its properties and set the Log On user. At that moment appropriate rights should be granted automatically, giving you rights to run your service. However those permissions are not sticky and you would need to repeat this each time server restarts.
  • However you can use Administrative Tools / Local Security Policy / Local Policies / User Rights Assignment to add user to "Log on as a service". This should grant given user permanent rights to restart the windows service.
share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.