Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm deploying liferay 6.0.6 server with a mysql cluster. When I start my liferay, it show error:

    You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near'OPTION SQL_SELECT_LIMIT=DEFAULT' at line 1.  

I run show variables like "%version%" in my sql client and get some output:

innodb_version: 5.6.11  
ndb_version:459522  
ndb_version_string:ndb-7.3.2  
ndbinfo_version:459522  
protocol_version:10  
version:5.6.11-ndb-7.3.2-cluster-gpl  
version_compile_machine:x86_64  
version_compile_os:linux-glibc2.5  

I try to replace my mysql.jar file in liferay/tomcat/lib/ext by mysql-connetor-java 5.1.22; 5.1.23; 5.1.25; 5.1.26, but it show the same error. What sould I do???

share|improve this question
    
I had my solution. If you "google" my error, the solution is replacing the mysql.jar file in /tomcat/lib/ext. But "tomcat/lib/ext" files can be overrided by lib files in "tomcat/webapp/ROOT/WEB-INF/lib". Someone in my team placed mysql-connector-java-5.1.31 in this directory and the same error show when I replace mysql.jar in "lib/ext" directory. –  supper aban_89 Aug 27 '13 at 3:34
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.