Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have been trying to fix this problem for a week now. My network has 2 ISP:

1: fixed IP -> Billion router -> mail and web servers
2: dynamic IP -> Linksys -> normal web browsing

They all used to work flawlessly until I reset the routers a week ago (following an advice by ISP to fix a problem). Until now I can make everything work except receiving mails from outside domains.

Billion - DHCP ( is turned off. Virtual servers in NAT page set to corresponding server local IPs.

Linksys - DHCP ( is set to relay to (I don't know why. It was set by former admin who quits 2 months ago) Single Port Forwarding was set like before.

Here is the DNS setting in DNS-DIY:

(blank) - A - (global IP)
* - A - (global IP)
www - A - (global IP)
(blank) - MX - mail
mail - MX - (global IP)

Telnetting the local IP and for 110 and 25 works, but doesn't.

Another thing I can tell is two routers are connected in some way. I don't know about details of the mail server. I am just a programmer and completely new to this network stuff. Even the network admin who quits 2 months ago cannot figure this out.

This issue is critical to the company I am working, so I need this fixed ASAP. I will provide any more information I can.

share|improve this question

Sorry for answering my own question, but I just figured a way.

At first I changed all the DNS settings to Linksys (dynamic IP). E-mail works well but this is not a permanent solution.

The mail server appears to be Ubuntu OS of some kind. I searched for command lines on Google and found out its default gateway is

So I set it to (fixed IP router) and now we can use the E-mail normally.

I don't know if there will be any more problems because of this change though.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.