Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm trying to move my company's phone system from Cisco's CUCM to an asterisk solution.

I have setup a PBXinaflash server, and setup an account with www.vitelity.com. I was able to get it working. I could send/receive calls, and it connected to an IVR.

Next I bought a Cisco 2821 ISR with a PRI card, as a backup for our current VOIP gateway. I was was able to load our current configuration on it, and after plugging in the PRI line it worked with our Cisco CUCM.

After that I did a goggle search on how to reconfigure the 2821. I downloaded the Cisco documentation on it, and found some example on Google. After my first try I was able to make outgoing phone calls. I was able to call a IVR and get it to recognize the digits I was dialing. The other phones Called ID showed the correct caller ID for us. The problem was getting incoming calls to work. So far I have gotten it to make a clicking sound, a dial tone, all line busy, and ring without any real phones ringing.

My objective it to get our asterisk IVR to pickup all calls on any of our phone numbers. We have ~150 DIDs, but only 4 are really used for anything.

My question is has anyone got this type of setup working? Is it possible? Could you share you configurations with me?

I think the problem is either the config for the 2821 or the trunk config in asterisk.

[Cisco 2821 ISR ~ 10.1.10.252]

version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname asterisk
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
!
no aaa new-model
clock timezone GMT -6
network-clock-participate wic 1 
network-clock-select 1 T1 0/1/0
!
dot11 syslog
ip source-route
!
ip cef
!
no ipv6 cef
!
multilink bundle-name authenticated
!
isdn switch-type primary-ni
!
voice rtp send-recv
!
voice service voip 
 allow-connections h323 to h323
 allow-connections h323 to sip
 allow-connections sip to h323
 allow-connections sip to sip
 redirect ip2ip
 signaling forward unconditional
 fax protocol cisco 
 sip
  bind control source-interface GigabitEthernet0/1
  bind media source-interface GigabitEthernet0/1
!
voice-card 0
 dspfarm
!
archive
 log config
  hidekeys
!
controller T1 0/1/0
 pri-group timeslots 1-24
!
interface GigabitEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 ip address 10.1.10.252 255.255.255.0
 duplex auto
 speed auto
!
interface Serial0/1/0:23
 no ip address
 encapsulation hdlc
 isdn switch-type primary-ni
 isdn incoming-voice voice
 isdn calling-number 3167945555
 isdn supp-service name calling
 no cdp enable
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 10.1.10.253
no ip http server
no ip http secure-server
!
control-plane
!
voice-port 0/1/0:23
!
no mgcp package-capability res-package
no mgcp package-capability fxr-package
no mgcp timer receive-rtcp
no mgcp explicit hookstate
!
dial-peer voice 1 pots
 numbering-type unknown
 destination-pattern .
 direct-inward-dial
 port 0/1/0:23
 forward-digits all
!
dial-peer voice 2 voip
 numbering-type unknown
 destination-pattern .
 session protocol sipv2
 session target ipv4:10.1.10.7:5060
 session transport udp
 dtmf-relay rtp-nte
 codec g711ulaw
!
gateway 
 timer receive-rtp 1200
!
sip-ua 
 retry invite 3
 retry response 3
 retry bye 3
 retry cancel 3
 timers trying 1000
 sip-server ipv4:10.1.10.7
!
line con 0
 transport output telnet
line aux 0
 transport output telnet
line vty 0 4
 login
 transport input telnet
line vty 5 15
 login
 transport input telnet
!
scheduler allocate 20000 1000
end

[asterisk trunk ~ 10.1.10.7]

Outgoing Settings

Trunk Name:
cisco2821

PEER Details:
type=friend
qualify=yes
nat=no
insecure=very
host=10.1.10.252
dtmfmode=rfc2833
disallow=all
context=from-internal
allow=ulaw&alaw

Incoming Settings

USER Context:
from-internal

USER Details:
type=friend
qualify=yes
nat=no
host=10.1.10.252
dtmfmode=rfc2833
disallow=all
context=from-trunk
canreinvite=no
allow=ulaw&alaw
share|improve this question

1 Answer 1

up vote 0 down vote accepted

OK I got it working, I needed to learn how to use the debugging logging on the 2821 ISR. Thanks to SkykingOH at freepbx.org for the help on this project.

debug isdn q931
debug voip dialpeer inout
debug voip dialpeer detail
debug ccsip states
debug ccsip info
debug ccsip calls
debug ccsip events
debug ccsip messages

I simplified the [asterisk trunk ~ 10.1.10.7] too

PEER Details:

type=friend
qualify=yes
nat=no
insecure=port,invite
host=10.1.10.252
dtmfmode=rfc2833
disallow=all
context=from-trunk
allow=ulaw

The config for the 2821

version 12.4
service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
no service password-encryption
!
hostname asterisk
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
enable password ********
!
no aaa new-model
clock timezone GMT -6
network-clock-participate wic 1 
network-clock-select 1 T1 0/1/0
!
dot11 syslog
ip source-route
!
!
ip cef
!
!
ip domain name *********.com
ip name-server 10.0.0.21
ip name-server 10.0.0.22
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
isdn switch-type primary-ni
!
!
voice rtp send-recv
!
voice service voip 
 allow-connections h323 to h323
 allow-connections h323 to sip
 allow-connections sip to h323
 allow-connections sip to sip
 redirect ip2ip
 signaling forward unconditional
 fax protocol cisco 
 sip
  bind control source-interface GigabitEthernet0/1
  bind media source-interface GigabitEthernet0/1
!
voice-card 0
 dspfarm
!
archive
 log config
  hidekeys
!
controller T1 0/1/0
 pri-group timeslots 1-24
!
interface GigabitEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 ip address 10.1.10.252 255.255.255.0
 duplex auto
 speed auto
!
interface Serial0/1/0:23
 no ip address
 encapsulation hdlc
 isdn switch-type primary-ni
 isdn incoming-voice voice
 isdn calling-number 316********
 isdn supp-service name calling
 no cdp enable
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 10.1.10.253
no ip http server
no ip http secure-server
!
!
ip dns server
!
logging trap warnings
logging 10.0.0.14
!
control-plane
!
voice-port 0/1/0:23
!
no mgcp package-capability res-package
no mgcp package-capability fxr-package
no mgcp timer receive-rtcp
no mgcp explicit hookstate
!
dial-peer voice 1 pots
 incoming called-number .
 direct-inward-dial
 port 0/1/0:23
 forward-digits all
!
dial-peer voice 2 voip
 destination-pattern ^[2-9]......$
 session protocol sipv2
 session target ipv4:10.1.10.7:5060
 session transport udp
 dtmf-relay rtp-nte
 codec g711ulaw
!
dial-peer voice 9001 pots
 preference 1
 destination-pattern .
 port 0/1/0:23
 forward-digits all
!
!
gateway 
 timer receive-rtp 1200
!
sip-ua 
 no remote-party-id
 retry invite 3
 retry response 3
 retry bye 3
 retry cancel 3
 timers trying 1000
 sip-server ipv4:10.1.10.7
!
!
!
line con 0
 transport output telnet
line aux 0
 transport output telnet
line vty 0 4
 login
 transport input telnet
line vty 5 15
 login
 transport input telnet
!
scheduler allocate 20000 1000
end

After using the debug I learned my telco (COX) was sending me 7 digits for our trunked numbers.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.