Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have an MDT task sequence that installs an OS and presents an application list based on your OU choice (differing departments need separate applications). When booting to WinPE and running the task sequence the selection options show properly and install fine.

However, when running the task sequence as a refresh from Windows, the application only shows the default panel with the sample application. According to the logs, it is accessing and running the right file (plus if it couldn't find the file, it would error out the task sequence) but not displaying properly.

Logs for the launch of this wizard are copied below:

Expand a string: WinPEandFullOS TSManager 8/23/2013 9:08:09 AM 17324 (0x43AC)
Executing command line: smsswd.exe /run: cscript.exe "%DeployRoot%\Scripts\UDIWizard.wsf" /definition:"AppLists\%OSDInstallOU%.xml" TSManager 8/23/2013 9:08:09 AM 17324 (0x43AC)
[ smsswd.exe ] InstallSoftware 8/23/2013 9:08:09 AM 12564 (0x3114)
PackageID = '' InstallSoftware 8/23/2013 9:08:09 AM 12564 (0x3114)
BaseVar = '', ContinueOnError='' InstallSoftware 8/23/2013 9:08:09 AM 12564 (0x3114)
ProgramName = 'cscript.exe "C:\_SMSTaskSequence\WDPackage\Scripts\UDIWizard.wsf" /definition:"AppLists\OSA.xml"' InstallSoftware 8/23/2013 9:08:09 AM 12564 (0x3114)
SwdAction = '0001' InstallSoftware 8/23/2013 9:08:09 AM 12564 (0x3114)
Working dir 'C:\_SMSTaskSequence\WDPackage\Tools\X64' InstallSoftware 8/23/2013 9:08:09 AM 12564 (0x3114)
Executing command line: Run command line InstallSoftware 8/23/2013 9:08:09 AM 12564 (0x3114)
Microsoft (R) Windows Script Host Version 5.8 InstallSoftware 8/23/2013 9:08:09 AM 12564 (0x3114)
Copyright (C) Microsoft Corporation. All rights reserved. InstallSoftware 8/23/2013 9:08:09 AM 12564 (0x3114)
InstallSoftware 8/23/2013 9:08:09 AM 12564 (0x3114)
Property definition is now = AppLists\OSA.xml InstallSoftware 8/23/2013 9:08:09 AM 12564 (0x3114)
Microsoft Deployment Toolkit version: 6.1.2373.0 InstallSoftware 8/23/2013 9:08:09 AM 12564 (0x3114)
The task sequencer log is located at C:\Windows\CCM\Logs\SMSTSLog\SMSTS.LOG.  For task sequence failures, please consult this log. InstallSoftware 8/23/2013 9:08:09 AM 12564 (0x3114)
Using tsprogressui.exe for displaying wizard UI InstallSoftware 8/23/2013 9:08:09 AM 12564 (0x3114)
Working directory: C:\_SMSTaskSequence\WDPackage\Tools\x64 InstallSoftware 8/23/2013 9:08:09 AM 12564 (0x3114)
Saving edited configuration file as C:\Windows\CCM\Logs\SMSTSLog\OSDSetupWizard.xml InstallSoftware 8/23/2013 9:08:09 AM 12564 (0x3114)
Copying app file C:\_SMSTaskSequence\WDPackage\Scripts\AppLists\OSA.xml.app to C:\Windows\CCM\Logs\SMSTSLog\OSDSetupWizard.xml.app InstallSoftware 8/23/2013 9:08:09 AM 12564 (0x3114)
Selected wizard stage option: REFRESH InstallSoftware 8/23/2013 9:08:09 AM 12564 (0x3114)
About to run command: ServiceUI.exe -process:tsprogressui.exe OSDSetupWizard.exe /xml:"C:\Windows\CCM\Logs\SMSTSLog\OSDSetupWizard.xml" /stage:REFRESH InstallSoftware 8/23/2013 9:08:09 AM 12564 (0x3114)

I could use some pointers on what is going wrong.

share|improve this question
    
Still having this issue occur, does anyone have any possible resolution? –  Ben M. Aug 28 '13 at 20:46

1 Answer 1

up vote 1 down vote accepted

On a refresh, in order to get the application list to show up on a second wizard, you must run the Application Discovery scan during the second wizard. It reads in the .xml.app file and populates the list.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.