Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Im using Solaris 10 with Samba 3.6.6. When I tried to access a share folder I get following error.

2013/08/27 02:43:38.450317,  4] smbd/reply.c:794(reply_tcon_and_X)
Client requested device type [?????] for share [IPC$]
[2013/08/27 02:43:38.450402,  3] lib/access.c:338(allow_access)
Allowed connection from 10.210.216.87 (10.210.216.87)
[2013/08/27 02:43:38.450619,  3] smbd/service.c:872(make_connection_snum)
Connect path is '/tmp' for service [IPC$]
[2013/08/27 02:43:38.450749,  3] smbd/vfs.c:102(vfs_init_default)
Initialising default vfs hooks
[2013/08/27 02:43:38.450818,  3] smbd/vfs.c:128(vfs_init_custom)
Initialising custom vfs hooks from [/[Default VFS]/]
[2013/08/27 02:43:38.451428,  4] smbd/sec_ctx.c:314(set_sec_ctx)
setting sec ctx (102740793, 100000513) - sec_ctx_stack_ndx = 0
[2013/08/27 02:43:38.451498,  0] lib/util.c:1117(smb_panic)
PANIC (pid 27019): sys_setgroups failed}

I added in the smb.conf the line "ignore syssetgroups error = yes", but testparm returned the error: Unknown parameter encountered: "ignore syssetgroups error" Ignoring unknown parameter "ignore syssetgroups error"

Do I need to upgrade the Samba version?

share|improve this question

1 Answer 1

Solved. Just need Solaris release 10 8/11. Add the following line in the /etc/system: set ngroups_max=1024 and reboot. You can refer to the following links:

http://www.nineproductions.com/solaris-10-samba-zfs-configuration/

http://docs.oracle.com/cd/E23823_01/html/821-2730/gkuhd.html#glapu

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.