Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I am encountering some difficulty with makeing the owner of files created in a particular directory to be the Built In Administrators group, rather than the actual user that created it. This seems to be the standard behavior on Windows Server 2003, but I can't figure out how to make it work on Server 2008 R2

The reason I want to do this is because the user that creates the files is a local user, and hence when I try to access information about the files created programatically, I can't translate the SID into a user account. Ideally if the files had their creator / owner as the built in Administrators group, it would have a well know SID that could be translated to a user account.

Any assistance would be greatly appreciated.

share|improve this question

1 Answer 1

For Old Files:

You can use a tool to do the job for you called "SubInACL.exe" that is part of the Windows Resource Kit Tools: http://www.microsoft.com/en-us/download/details.aspx?id=23510

The tool is easy to use, here's an example for changing an ownership of a text file:

Subinacl /File TestFile.txt /Setowner=Domain\User

Edit 1: For Newly Created Files:

You're in luck, the option is not included in Windows 2008, but you can add it later on and make it work just like Windows 2003, the steps are too long to fit in here though, so I'll just paste a link for them: http://kamalblogs.wordpress.com/2010/08/03/setting-default-object-owner-as-object-creator-in-window-server-2008-for-aif-in-dynamics-ax/

Edit 2: It appears there's a tool to do this already in here: http://floditt.blogspot.com/2011/01/aif-message-header-editor-reloaded.html

Hope this helps.

share|improve this answer
    
This will change the owner of existing files, yes, but I believe OP is asking how to set the owner for newly created files as well. –  jscott Aug 28 '13 at 12:30
    
Oh, my bad, the steps to do this for newly created files is too damn long, I'll edit my answer to include this. –  Noor Aug 28 '13 at 12:48
    
Thanks for your suggestions. As it turns out my IT department managed to fix it. Will check with them what they did and write up what their solution was tomorrow. –  AshtonKJ Aug 28 '13 at 15:32

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.