Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I did a server restart for my web server and on restart, MySQL won't start. If I use taskmanager to kill mysqld.exe and try the start from services console, it gets about 50% through the startup, stalls for a long time, and when it eventually finishes it shows the message:

"Windows could not start the MySQL service on Local Computer. Error 1053: The service did not respond to the start or control request in a timely fashion."

I had this once before and from memory all I had to do to correct it was delete the ib_logfile0 and ib_logfile1 files.

This has not helped this time.

Please help! I have 9 websites down and need them backup ASAP.

UPDATE:

An update on this... If I change the default database engine in my.ini from InnoDB to MyISAM and enable the skip_innodb option, the MySQL service starts. But none of the websites work properly. (eg. If I go to a wordpress site, it loads the Wordpress installation wizard instead of the existing website). So I think it has something to do with INNODB.

UPDATE 2:

MySQL Error log last entries (before I deleted the .err file):

Version: '5.1.66-community'  socket: ''  port: 3306  MySQL Community Server (GPL)
130829  9:47:27 [Note] C:\Program Files\MySQL\MySQL Server 5.1\bin\mysqld: Normal shutdown

130829  9:47:27 [Note] Event Scheduler: Purging the queue. 0 events
130829  9:47:27  InnoDB: Starting shutdown...
130829  9:47:29  InnoDB: Shutdown completed; log sequence number 0 725928381
130829  9:47:29 [Note] C:\Program Files\MySQL\MySQL Server 5.1\bin\mysqld: Shutdown complete

130829 11:49:13 [Note] Plugin 'FEDERATED' is disabled.
130829 11:49:14  InnoDB: Initializing buffer pool, size = 47.0M
130829 11:49:15  InnoDB: Completed initialization of buffer pool
130829 11:49:18  InnoDB: Started; log sequence number 0 725928381
130829 12:04:26 [Note] Event Scheduler: Loaded 0 events
130829 12:04:26 [Note] C:\Program Files\MySQL\MySQL Server 5.1\bin\mysqld: ready for connections.
Version: '5.1.66-community'  socket: ''  port: 3306  MySQL Community Server (GPL)
130829 12:14:22 [Note] Plugin 'FEDERATED' is disabled.
130829 12:14:22 [Note] Plugin 'InnoDB' is disabled.
130829 12:14:23 [Note] Event Scheduler: Loaded 0 events
130829 12:14:23 [Note] C:\Program Files\MySQL\MySQL Server 5.1\bin\mysqld: ready for connections.
Version: '5.1.66-community'  socket: ''  port: 3306  MySQL Community Server (GPL)
130829 12:28:45 [Note] C:\Program Files\MySQL\MySQL Server 5.1\bin\mysqld: Normal shutdown

130829 12:28:45 [Note] Event Scheduler: Purging the queue. 0 events
130829 12:28:45 [Note] C:\Program Files\MySQL\MySQL Server 5.1\bin\mysqld: Shutdown complete

enter code here
enter code here
share|improve this question
    
what about mysql logs? –  GioMac Aug 29 '13 at 9:42
    
Are you referring to the "server_name".err files in the data folder? There was nothing useful in there that tells me where it's getting stuck or why. Is there another logging that can be turned on? –  Reece Dodds Aug 29 '13 at 23:43
    
yes, please copy contents somewhere –  GioMac Aug 29 '13 at 23:46

1 Answer 1

up vote 0 down vote accepted

I managed to get it working again late yesterday afternoon by removing the existing ib_logfile* files, the existing MYSERVER.err file (which was 981KB by the way) and making the following changes to the my.ini file:

  • increased innodb_additional_mem_pool_size from 2M to 100M

  • increased innodb_buffer_pool_size from 47M to 100M

  • increased innodb_log_file_size from 24M to 50M

I don't know what possessed me to change these, but I was at a "almost at last resort" stage (which would've been to build a new VM guest and configure IIS/MySQL/PHP from scratch).
How or why these changes made a difference, I don't know, but at least it's working again.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.