Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I am seeing this SPF softfail for emails sent from my server, and I notice that 2a01:4f8:121:2062::2 is an IPV6 address. When I check 2a01:4f8:121:2062::2 it is translated as 0.0.0.2 ipv4, so that ipv6 address seems bogus.

I have a Centos server that does not have ipv6 configured, and I left everything at default.

How can I solve this? Should I disable ipv6 on my server? Is postfix responsible for this? Why postfix sends mail with ipv6 when I never configured it?

As requested (I redacted my valid ipv4 address with XX)

[root@host ~]# ifconfig -a

eth0      Link encap:Ethernet  HWaddr XX:XX:XX:2B:97:82
          inet addr:XX.XXX.XXX.XX  Bcast:XX.XXX.XXX.XX  Mask:255.255.255.255
          inet6 addr: 2a01:4f8:121:2062::2/64 Scope:Global
          inet6 addr: fe80::4261:86ff:fe2b:9782/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:5906959065 errors:0 dropped:0 overruns:0 frame:0
          TX packets:3933424961 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:6766726597523 (6.1 TiB)  TX bytes:1315274953503 (1.1 TiB)

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:34502551 errors:0 dropped:0 overruns:0 frame:0
          TX packets:34502551 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:37797695084 (35.2 GiB)  TX bytes:37797695084 (35.2 GiB)`
share|improve this question
2  
Just because you didn't configure it no longer means that v6 isn't configured; if your ISP provides the right infrastructure, v6 will quite happily autoconfigure itself. Could you edit the output of ifconfig -a into the question? –  MadHatter Aug 29 '13 at 8:19
    
Yep, thx. Added. My ipv6 looks bogus there as well :) Looks like I have to disable or configure ipv6... –  giorgio79 Aug 29 '13 at 8:30
4  
That is not an auto-configured IPv6 address... That is an IPv6 address that Macadu (you I presume?) got from Hetzner. It seems to be your address on a Hetzner server and you probably should configure reverse DNS for it and change your SPF records. Having IPv6 is a good thing! :-) –  Sander Steffann Aug 29 '13 at 8:41
    
Thx. :) Wow, this ipv6 converter showed that ipv6 address as 0.0.0.2 (subnetonline.com/pages/subnet-calculators/…) –  giorgio79 Aug 29 '13 at 8:58
1  
I'm not sure what you mean by converting an ipv6 address to ipv4. That's not how v6 works. –  MadHatter Aug 29 '13 at 9:20

1 Answer 1

up vote 3 down vote accepted

We've established that your server is, in fact, configured for ipv6, and has a perfectly globally-valid address. I think that disposes of the original question.

If you didn't know you were running v6, you should probably check your ip6tables rules, since it might be participating in all sorts of conversations you neither know about nor want! In case further proof was wanted (I have v6 to my desktop):

[me@risby ~]$ telnet 2a01:4f8:121:2062::2 110
Trying 2a01:4f8:121:2062::2...
Connected to 2a01:4f8:121:2062::2.
Escape character is '^]'.
+OK Dovecot ready.
quit
+OK Logging out
Connection closed by foreign host.

If you'd prefer not to be running v6, you can disable it with

IPV6INIT=no
IPV6_AUTOCONF=no

in /etc/sysconfig/network-scripts/ifcfg-eth0, though personally I think v6 is the coming wave and you've got a great opportunity to play with it!

share|improve this answer
    
thx, much appreciated! –  giorgio79 Aug 29 '13 at 9:00
    
IPv6 isn't really optional anymore. –  Michael Hampton Aug 29 '13 at 14:54
    
Hey, I find that behaving like an ostrich is always an option! –  MadHatter Aug 29 '13 at 15:08

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.