Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

On my windows 2003 I have to run sfc /scannow as admin. I have tried to run it as local administrator and domain administrator, but it says I need of administrator privilege ????

I have tried runas /user:administrator cmd and then on a new shell sfc /scannow. But it does not work too.

The error message is:

You must be an administrator running a console session in order to use the Windows File Checker utility.

the error message is in italian and should be translated in english as above. The following is the cmd's screenshot of the error. I am connected as domain administrator but I run it a runas to be local admin.

cmd with administrator privilege on rdp

share|improve this question
    
You talk about error messages...what are they? It would help if we see the error verbatim and whether you are at the server or RDP'd into it. –  TheCleaner Aug 29 '13 at 17:35
    
The message from Windows 2003 is not very clear. It talks about "console" -> "You must be an administrator running a console session in order to use the Windows File Checker utility." which at first sight I was taking for a "console window" but it's actually /Console switch as per my answer. –  MadBoy Aug 29 '13 at 17:59
add comment

2 Answers

up vote 3 down vote accepted

You need to choose Run as on CMD and type in login and password of Administrator. Then you can run the command. You need to be logged in RDP in CONSOLE mode (/console or /admin switch depending on RDP version). Then it will work.

enter image description here

share|improve this answer
    
does not work, the same error messages –  Luigi Aug 29 '13 at 16:51
    
see my edit, it seems Windows 2003 has need for a bit of "play" –  MadBoy Aug 29 '13 at 16:55
    
your edit is the correct answer. –  Luigi Aug 30 '13 at 8:33
    
It worked for me. Followed the below command in RUN window. "mstsc /console /admin" login to your server/Desktop system remotly. Then do "CMD" run as admin. Now you will not see and issue and will get all option on running "SFC" –  user189443 Sep 11 '13 at 5:53
add comment

i know this might be obvious but i had the same problem even though i am the only user but i pulled up start typed cmd right clicked and chose run as admin and it worked for me

win 7 64bit

share|improve this answer
    
This does not provide an answer to the question. To critique or request clarification from an author, leave a comment below their post - you can always comment on your own posts, and once you have sufficient reputation you will be able to comment on any post. –  slm Mar 14 at 22:39
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.