Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have actually two problems with my server. The setup is like this:

  • server in a data center connected directly to the internet
  • one network card / two public IPs (one IP the server gets over DHCP, the other has to be configured manually)
  • Debian wheezy as kvm host
  • Debian wheezy as guest

First problem is that I don't get network connection on the guest at all. Second problem is that I want the guest to responde to one of the IP addresses. The second IP I want to use to manage the host.

Let's start with the first problem. Here is the interfaces file of the host:

auto lo
iface lo inet loopback

auto eth0
iface eth0 inet manual

auto eth0:0
iface eth0:0 inet static 
address XX.YYY.ZZZ.161
network XX.YYY.ZZZ.161
netmask 255.255.255.255
broadcast XX.YYY.ZZZ.255
gateway AA.BBB.CCC.1

auto br0
iface br0 inet dhcp
bridge_ports eth0
bridge_stp off
bridge_maxwait  0
bridge_fd       0

With this configuration br0 gets the IP address from DHCP and I can reach the host server on both IP addresses. The host can also ping Google. Very well.

Now I start the guest.

root@debianvmhost:~# brctl show

bridge name     bridge id               STP enabled     interfaces
br0             8000.002590a31dee       no              eth0
                                                        vnet0

Seems like the vm is connected to the bridge.

root@debianvmhost:~# ps -ef | grep qemu

/usr/bin/kvm ... 
-netdev tap,fd=20,id=hostnet0,vhost=on,vhostfd=21 
-device virtio-net-pci,netdev=hostnet0,id=net0,
mac=52:54:xx:xx:xx:xx,bus=pci.0,addr=0x3 

So far, so good. But the vm does not get any IP address. When I manually set one of the public IP addresses I still do not get network access. I cannot poing th IP address of Google, the network is not reachable.

What do I do wrong?

Thanks in advance

Jaroslaw

Edit: Sorry, commenting does not work on my mobile. The hoster is Strato.

share|improve this question

1 Answer 1

You can try to use bridge mode for this. But it is possible that your ISP most likely will block the traffic originated from MAC ADDRESS different than hosts NIC as they will only allow one MAC per switchport.

But if not you could try to use this tutorial: http://wiki.hetzner.de/index.php/KVM/en

EDIT: Missed that you are getting second IP through DHCP. In that case I actually do not know how to do it through bridge mode.

share|improve this answer
    
Yes, you are right. Strato confimed that they filter traffic from unknown MAC addresses. I will have to try it with NAT. Thanks. –  Jaroslaw S. Sep 16 '13 at 13:46

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.