Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am getting initramfs error. I found Ubuntu server won't boot, stops at initramfs link on ServerFault. But the solution didn't worked for me.

Please suggest the solution. Any help would be appreciated.

share|improve this question

closed as unclear what you're asking by MikeyB, Chris S Oct 16 '13 at 16:05

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question.If this question can be reworded to fit the rules in the help center, please edit the question.

    
Probably, the required hardware support is not contained in your kernel nor present as a module in your initial RAM disk in order to boot your system. –  Marki Aug 30 '13 at 8:26
    
I have a question - did it work before or it's brand new thing you're trying? –  Str82DHeaD Aug 30 '13 at 8:48
    
This error some times came to me but i ignored it before but now it is urgent for me to resolve. I answered my own question. Thanks –  GaganVERMA Aug 30 '13 at 8:56
    
The error you've cited is far, FAR too generic to be of any help in the future. The solution you've posted is potentially dangerous (removing the filesystem journal) and unlikely to be of any benefit to future users. –  MikeyB Oct 16 '13 at 15:53
add comment

1 Answer

up vote 0 down vote accepted

I found the solution on this link. This worked perfectly for me.

Solution

I have the same problem...I did some commands in the terminal after logging into the live cd

The following step is for removing the i-node

In the terminal I typed

sudo debugfs -w /dev/sda1
debugfs 1.41.11 (14-Mar-2010)
debugfs: clri <8>
debugfs: quit

After that restart the system and again boot into the live cd

In the terminal type

sudo fsck -yv /dev/sda1

It will work.....definitely

After logging into the desktop in the terminal type the following commands

sudo apt-get update
sudo apt-get autoclean
sudo apt-get check

For More Details visit the tutorial page

http://dcageek.blogspot.com/2013/02/ubuntu-initramfs-error-during-boot.html

For More Visit details

http://dcageek.blogspot.com

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.