Sign up ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I've recently setup a LAMP (Fedora 18) server to serve a website on a local network. It was all working, then I made a minor change to php.ini, restarted, and it failed. The only thing that had changed since apache was last started was that a DNS entry was added on the network.

systemctl status httpd.service
httpd.service - The Apache HTTP Server
      Loaded: loaded (/usr/lib/systemd/system/httpd.service; enabled)
      Active: failed (Result: exit-code) since Fri, 2013-08-30 09:02:42 BST; 44min ago
     Process: 9769 ExecStop=/usr/sbin/httpd $OPTIONS -k graceful-stop (code=exited, status=0/SUCCESS)
     Process: 9767 ExecStart=/usr/sbin/httpd $OPTIONS -DFOREGROUND (code=exited, status=1/FAILURE)
      CGroup: name=systemd:/system/httpd.service

Aug 30 09:02:42 systemd[1]: httpd.service: main process exited, code=exited, status=1/FAILURE
Aug 30 09:02:42 httpd[9769]: httpd (no pid file) not running
Aug 30 09:02:42 systemd[1]: Failed to start The Apache HTTP Server.
Aug 30 09:02:42 systemd[1]: Unit httpd.service entered failed state

# vi /var/log/httpd/error_log
[Fri Aug 30 09:02:42.497697 2013] [suexec:notice] [pid 9767] AH01232: suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
[Fri Aug 30 09:02:42.568620 2013] [unique_id:alert] [pid 9767] (EAI 2)Name or service not known: AH01564: unable to find IPv4 address of ""
AH00016: Configuration Failed

# vi /etc/hosts               localhost.localdomain localhost
::1             localhost6.localdomain6 localhost6

# vi /etc/hostname

httpd.conf has contained




<VirtualHost *:80>
DocumentRoot /var/www/bugagon
ErrorLog /var/log/httpd/bugagon/error_log
CustomLog /var/log/httpd/bugagon/access_log common

SElinux is disabled, the change in php.ini was just changing SMTP localhost to SMTP and the IP address of the MTA server. I've changed it back, didn't have any visible effect.

...I'm not a Linux expert, but I've looked at all the forums I can find and I haven't been able to fix the issue. Can anyone offer any suggestions?

Thanks in advance, Richard.

share|improve this question

1 Answer 1

up vote 1 down vote accepted

Replace "@" with "." :)

share|improve this answer
Problem solved, thank you very much! – Richard Aug 30 '13 at 10:19

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.