Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

My configuration of dovecot - postfix - postfixadmin won't work.

Since i'm pretty new to emails, i followed this tutorial

My server is an Ubuntu 13.04 server. Email sending from localhost works as intended and mx records are setup correctly.

Here's the error in mail.err and when i try to connect to my mailbox with MS Outlook 2013

 Aug 31 06:00:15 NewWeb dovecot: imap(cappyt@xxxxx.it): Error: user cappyt@xxxxx.it: Initialization failed: Namespace '': mkdir(/home/vmail/xxxxx.it/cappyt) failed: Permission denied (euid=5000(vmail) egid=5000(vmail) missing +w perm: /home, dir owned by 0:0 mode=0755)
Aug 31 06:00:15 NewWeb dovecot: imap(cappyt@xxxxx.it): Error: Invalid user settings. Refer to server log for more information.

And here in mail.log

Aug 31 06:00:01 NewWeb postfix/pickup[8523]: 28C8481010: uid=107 from=<smmsp>
Aug 31 06:00:01 NewWeb postfix/cleanup[12949]: 28C8481010: message-id=<20130831040001.28C8481010@mail.xxxxx.it>
Aug 31 06:00:01 NewWeb postfix/qmgr[8524]: 28C8481010: from=<smmsp@mail.xxxxx.it>, size=709, nrcpt=1 (queue active)
Aug 31 06:00:01 NewWeb postfix/local[12953]: 28C8481010: to=<root@mail.xxxxx.it>, orig_to=<root>, relay=local, delay=0.02, delays=0.01/0.01/0/0, dsn=2.0.0, status=sent (delivered to command: procmail -a "$EXTENSION")
Aug 31 06:00:01 NewWeb postfix/qmgr[8524]: 28C8481010: removed
Aug 31 06:00:12 NewWeb dovecot: config: Warning: NOTE: You can get a new clean config file with: doveconf -n > dovecot-new.conf
Aug 31 06:00:12 NewWeb dovecot: config: Warning: Obsolete setting in /etc/dovecot/dovecot.conf:102: add auth_ prefix to all settings inside auth {} and remove the auth {} section completely
Aug 31 06:00:12 NewWeb dovecot: config: Warning: Obsolete setting in /etc/dovecot/dovecot.conf:103: userdb sql {} has been replaced by userdb { driver=sql }
Aug 31 06:00:12 NewWeb dovecot: config: Warning: Obsolete setting in /etc/dovecot/dovecot.conf:106: passdb sql {} has been replaced by passdb { driver=sql }
Aug 31 06:00:12 NewWeb dovecot: auth-worker(12961): mysql(yy.yy.yy.yy): Connected to database postfix_mail
Aug 31 06:00:15 NewWeb dovecot: imap-login: Login: user=<cappyt@xxxxx.it>, method=PLAIN, rip=x.x.x.x, lip=yy.yy.yy.yy, mpid=12963, TLS, session=<yHREYDblxgCf/4PT>
Aug 31 06:00:15 NewWeb dovecot: imap(cappyt@xxxxx.it): Error: user cappyt@xxxxx.it: Initialization failed: Namespace '': mkdir(/home/vmail/xxxxx.it/cappyt) failed: Permission denied (euid=5000(vmail) egid=5000(vmail) missing +w perm: /home, dir owned by 0:0 mode=0755)
Aug 31 06:00:15 NewWeb dovecot: imap(cappyt@xxxxx.it): Error: Invalid user settings. Refer to server log for more information.
Aug 31 06:00:15 NewWeb postfix/smtpd[12964]: connect from ip-159-255-131-211.in-addr.ntrnet.it[x.x.x.x]
Aug 31 06:00:15 NewWeb postfix/smtpd[12964]: warning: ip-159-255-131-211.in-addr.ntrnet.it[x.x.x.x]: SASL LOGIN authentication failed: no mechanism available
Aug 31 06:00:15 NewWeb postfix/smtpd[12964]: lost connection after AUTH from ip-159-255-131-211.in-addr.ntrnet.it[x.x.x.x]
Aug 31 06:00:15 NewWeb postfix/smtpd[12964]: disconnect from ip-159-255-131-211.in-addr.ntrnet.it[x.x.x.x]

I really don't know where's the problem, since write permissions has been applied to /var/vmail to user vmail:vmail (5000:5000)

Also if other configuration is needed, ask in comments.

share|improve this question

1 Answer 1

As per error it is showing problem in ownership permission at /home/vmail ,not in /var/vmail Check your configuration where you have to specify the maildir (search in dovecot.conf mail_location) .If possible can you paste the mail_location setting

share|improve this answer
    
Ok, corrected that line, it was pointing in /home/vmail and not in /var/vmail For the sasl errors, i corrected them following this tutorial: microbits.info/index.php/2012/06/… Any advice for hardening/antispam filters setup? –  CappyT Sep 2 '13 at 20:03

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.