Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I can't seem to get CPAN installs working on a Solaris machine. Here is my current output.

~# perl -MCPAN -eshell
Terminal does not support AddHistory.

cpan shell -- CPAN exploration and modules installation (v1.7601)
ReadLine support available (try 'install Bundle::CPAN')

cpan> install Bundle::LWP                 
CPAN: Storable loaded ok
LWP not available
CPAN: Net::FTP loaded ok
Fetching with Net::FTP:
  ftp://ftp.dti.ad.jp/pub/lang/CPAN/authors/01mailrc.txt.gz
Couldn't fetch 01mailrc.txt.gz from ftp.dti.ad.jp
...
...

This output is repeated for every mirror. Any ideas why this doesn't work?

share|improve this question
add comment

2 Answers

up vote 3 down vote accepted

There's a few possibilities of what it could be, but the most typical issue is that you're behind a firewall that requires you to use passive FTP. You can either look for an HTTP mirror, or try setting the environmental variable FTP_PASSIVE to a true value before running cpan.

share|improve this answer
1  
export FTP_PASSIVE=1 –  Casey Aug 13 '09 at 5:05
    
Yes, this was it. I ended up figuring this out before I saw your post. Hope this helps someone else. –  Casey Aug 13 '09 at 5:05
add comment

As root

/usr/perl5/5.8.4/bin/perlgcc -MCPAN -e shell

seems to have done the trick for me. I am on solaris 10 update 6 on sparc.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.