Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am trying to send a mail from my website through smtp.live.com port 587. I verified the credentials and even tried to send the email from Gmail by adding the account there and sending through it. On Gmail it works, on my server it doesn't

I get the following error :

{ [SenderError: Mail from command failed - 501 5.5.4 Invalid Email address] name: 'SenderError', data: '501 5.5.4 Invalid Email address' }

I am using nodemailer to send the mail

Can anyone give me some information about this error message ?

share|improve this question

closed as off-topic by Jenny D, mdpc, HBruijn, Katherine Villyard, Ward Nov 21 '14 at 3:12

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions must be relevant to professional system administration. Server Fault is dedicated to professional system and network administrators. End user and enthusiast questions are off-topic (contact your system administrator or hire a professional to help you out). Please see the Help Center for more information." – Jenny D, mdpc, HBruijn, Katherine Villyard, Ward
If this question can be reworded to fit the rules in the help center, please edit the question.

Turns out the module that sent the email didn't specify a from field and it was sending it blank. The Outlook smtp server wasn't tolerant about this and threw an error.

Specifically adding from to the email solved the problem

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.