Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am setting up a virtual server network on Azure.

1) Active Dir - Windows Server 2012 Datacenter
2) SQL Server - Windows Server 2012 Datacenter
3) App Server - Windows Server 2008 R2 Datacenter
4) App Server - Windows Server 2012 Datacenter

All servers visible in Active Directory & All servers have IP's

SQL Server firewall setup in/out rules for sql default port 1433

App Servers can ping the SQL Server using machine name and IP

I have confirmed SQL Server is listening on port 1433 using Port Query utility.

To test SQL Connectivity I create a connection.udl file on each app server and double click it to open the UI.

I then configure it to connect to the SQL server using machine name with the MS OLE DB Provider for SQL Server and click the "Test the Connection" button which returns error:

---------------------------
Microsoft Data Link Error
---------------------------
Test connection failed because of an error in initializing provider. [DBNETLIB][ConnectionOpen (Connect()).]Specified SQL server not found.
---------------------------
OK   
---------------------------

I then change the configuration to use the IP address of the SQL Server instead of the machine name and the connection succeeds.

What settings should be altered on any or all of these machines to be sure the connection succeeds using the machine name? This is very odd considering the app servers can ping the sql server using IP or machine name.

share|improve this question
    
Update. If I enter the fully qualified name of the server then it works. I am not sure if this is by design but it works. –  ChiliYago Aug 31 '13 at 14:39
    
Soon after; that same configuration using the fully qualified name of the sql server began failing again. –  ChiliYago Aug 31 '13 at 14:45
    
seems like some intermittent issue... very difficult to pinpoint –  ChiliYago Aug 31 '13 at 14:46

1 Answer 1

The issue here is that SQL Server 2012 now REQUIRES you specify the port even if the default 1433 is used. Specifying the <>,<> is required to make the connection work properly.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.