Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm trying to install a Scientific Linux CERN 6 guest on XenServer 6.2 through the network with PXE Booting but it hangs in the message:

mounting /tmp as tmpfs... done

I'm not using the most equivalent template (the CentOS 6 template) to install this VM, since we want to install it through our PXE Server, because it gets our kickstart file and create the VM with our necessities, and using the template there's no option to boot from the network. So the "Other Install Media" template was used.

I've tried other RHEL based distros, like clean Scientific Linux 6 (not the CERN flavour) and CentOS 6. All of the three got same problem.

Other distros, like Debian and Ubuntu installs fine with this method, and even the older 5.x version of Scientific Linux installs fine.

I think there's something related with the Xen Support removal from the profitable company on the upstream to force their virtualization solution. But I can't confirm if this is really the issue.

share|improve this question
    
I am having the same problem with Clear OS Community v6.5.0. –  jimp Feb 21 at 23:50

2 Answers 2

up vote 3 down vote accepted

when I tried to install I had the same problem. using the procedure in xenserver (cli)

xe vm-list

get uuid of your vm

xe vm-param-set uuid=uuid_of_your_virtual_machine platform:viridian=false

I could continue the installation.

share|improve this answer
    
This appears to be related to this bug: bugzilla.redhat.com/show_bug.cgi?id=918239#c13 –  Vinícius Ferrão Oct 18 '13 at 19:18
1  
+1 The installer for Clear OS Community v6.5.0 succeeded with this work-around. –  jimp Feb 21 at 23:51

We had this problem as well. You need to use text mode, or disable/downshift the graphical install during the netboot. On your kernel options pass nohz=off highres=off See: https://bugzilla.redhat.com/show_bug.cgi?id=632811

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.