Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

i'm trying to setup a small fileserver using GlusterFs over Zfs over two boxes that are currently running ubuntu 13.04.

i'm currently using glusterfs and zfs-fuse from ubuntu repositories and with those packages i've been able to create successfully a replicated gluster volume over xfs.

i've been also able to create zfs volumes with no issues at all.

The issuses starts when i try to create a gluster volume over a zfs path: after issuing the command

volume create apache-config-hosting replica 2 san1.local:/zfsroot/apache-config-hosting san2.local:/zfsroot/apache-config-hosting

i get:

2013 Sep  3 11:05:29 san1 [2013-09-03 11:05:29.962269] C [posix.c:4723:init] 0-apache-config-hosting-posix: Extended attribute not supported, exiting.

following advices from various tutorials i checked also xattr support with:

zfs get xattr

and i get

zfsroot/apache-config-hosting  xattr                 on                              default

which means that it sould be up and running. What am i missing?

EDIT: (adding content of /etc/zfs/zfsrc )

vdev-cache-size = 10
max-arc-size = 100
zfs-prefetch-disable
fuse-attr-timeout = 3600
fuse-entry-timeout = 3600
fuse-mount-options = default_permissions
share|improve this question
    
Could you please share the file /etc/zfs/zfsrc? –  dsmsk80 Sep 3 '13 at 11:25
    
hi, i've edited original post with the required info, thanks for help. This config file has not been edited at all, btw. –  Valerio Minetti Sep 3 '13 at 11:42
1  
What version of zfs fuse do you have installed? Could you try to put enable-xattr line to the aforementioned file and restart the service? –  dsmsk80 Sep 3 '13 at 12:11
    
thanks a lot. adding enable-xattr from xfsrc made it stop complaining at volume creation. i'll do a couple of tests and then i'll mark reply as correct :) –  Valerio Minetti Sep 3 '13 at 13:55
add comment

1 Answer

up vote 1 down vote accepted

The ZFS filesystem daemon is either configurable by passing it right command line arguments or by putting them to the configuration file /etc/zfs/zfsrc.

Version 0.7.0 of the daemon brought a new flag enable-xattr which enables support for extended attributes. Put this flag to the configuration file, restart the daemon and it should work. Keep in mind that the current implementation may cause a significant performance drop when small IOPS are prevailing.

share|improve this answer
    
thanks for the explanation, it's quite misleading the fact that zfs get xattr states they are on while they are not in reality. –  Valerio Minetti Sep 4 '13 at 12:36
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.