Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

As the question states, I have an OSX client that is currently not a member of the domain.

I am trying to access the SMB shares of the samba4 (Go to server -> smb://server) and I am being prompted to enter my username and password.

When I enter my password nothing happens, Finder remains in a "Connecting..." state but it never connects. I've tried to get a tcpdump to see the exchanged packets and I think that the password is never sent across but I might be wrong.

I've also tried to enable debugging on samba4 but I couldn't make something out of it.

Note that the username I am using, logs in properly from Windows clients. Samba5 has been configured by following the tutorial found here https://wiki.samba.org/index.php/Samba_AD_DC_HOWTO

Could you please help me debug this?

EDIT:

As requested, OSX client is 10.8.4. It is not a member of the domain and just tries to access the share files using the username/password in the domain controller (Samba4)

share|improve this question
1  
The last 3 versions of OSX all used different implementations of Samba, to diagnose this further you're going to have to be a little more specific. What Version(s) of OSX are you running, is this using domain authentication etc. –  Alex Berry Sep 16 '13 at 15:28
    
@AlexBerry I've updated the question as requested –  mobius Sep 17 '13 at 6:32

1 Answer 1

I solved all my Apple+Samba issues by also installing Netatalk (AFPd) on the server in question... 'They' say the Apple SMB implementation is really poor.

share|improve this answer
    
Care to elaborate a bit on this? So just installing afpd will make samba4 work? Is this an alternative? –  mobius Sep 13 '13 at 11:08
    
@mobius It's an alternative. You just make that data available through another service as well. You have to install it, and configure your share. Apple clients will connect with AFP and Windows with SMB. –  Halfgaar Sep 13 '13 at 11:29

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.