Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm having dependency issues while trying to update Centos 6.4 ,64 bit here is the output when I run yum update:

yum update
Loaded plugins: fastestmirror, priorities, refresh-packagekit, security
Loading mirror speeds from cached hostfile
 * base: centos.mirroring.pulsant.co.uk
 * epel: ftp.nluug.nl
 * extras: centos.mirroring.pulsant.co.uk
 * rpmforge: mirrors.ircam.fr
 * updates: centos.mirroring.pulsant.co.uk
1268 packages excluded due to repository priority protections
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package bash.x86_64 0:4.1.2-14.el6 will be updated
---> Package bash.x86_64 0:4.1.2-15.el6_4 will be an update
---> Package bind-libs.x86_64 32:9.8.2-0.17.rc1.el6_4.4 will be updated
---> Package bind-libs.x86_64 32:9.8.2-0.17.rc1.el6_4.6 will be an update
---> Package bind-utils.x86_64 32:9.8.2-0.17.rc1.el6_4.4 will be updated
---> Package bind-utils.x86_64 32:9.8.2-0.17.rc1.el6_4.6 will be an update
---> Package busybox.x86_64 1:1.15.1-15.el6 will be updated
---> Package busybox.x86_64 1:1.15.1-16.el6_4 will be an update
---> Package clusterlib.x86_64 0:3.0.12.1-49.el6_4.1 will be updated
---> Package clusterlib.x86_64 0:3.0.12.1-49.el6_4.2 will be an update
---> Package cman.x86_64 0:3.0.12.1-49.el6_4.1 will be updated
---> Package cman.x86_64 0:3.0.12.1-49.el6_4.2 will be an update
---> Package cpuspeed.x86_64 1:1.5-19.el6 will be updated
---> Package cpuspeed.x86_64 1:1.5-20.el6_4 will be an update
---> Package crash-gcore-command.x86_64 0:1.0-3.el6 will be updated
---> Package crash-gcore-command.x86_64 0:1.0-4.el6_4 will be an update
---> Package cups.x86_64 1:1.4.2-50.el6_4.4 will be updated
---> Package cups.x86_64 1:1.4.2-50.el6_4.5 will be an update
---> Package cups-libs.x86_64 1:1.4.2-50.el6_4.4 will be updated
---> Package cups-libs.x86_64 1:1.4.2-50.el6_4.5 will be an update
---> Package firefox.x86_64 0:17.0.6-1.el6.centos will be updated
---> Package firefox.x86_64 0:17.0.8-1.el6.centos will be an update
--> Processing Dependency: xulrunner >= 17.0.8 for package: firefox-17.0.8-1.el6.centos.x86_64
---> Package glibc.x86_64 0:2.12-1.107.el6_4.2 will be updated
---> Package glibc.x86_64 0:2.12-1.107.el6_4.4 will be an update
---> Package glibc-common.x86_64 0:2.12-1.107.el6_4.2 will be updated
---> Package glibc-common.x86_64 0:2.12-1.107.el6_4.4 will be an update
---> Package glibc-devel.x86_64 0:2.12-1.107.el6_4.2 will be updated
---> Package glibc-devel.x86_64 0:2.12-1.107.el6_4.4 will be an update
---> Package glibc-headers.x86_64 0:2.12-1.107.el6_4.2 will be updated
---> Package glibc-headers.x86_64 0:2.12-1.107.el6_4.4 will be an update
---> Package gnome-screensaver.x86_64 0:2.28.3-24.el6 will be updated
---> Package gnome-screensaver.x86_64 0:2.28.3-24.el6_4.1 will be an update
---> Package gstreamer-plugins-bad.x86_64 0:0.10.19-9.el6 will be obsoleting
--> Processing Dependency: libxvidcore.so.4()(64bit) for package: gstreamer-plugins-bad-0.10.19-9.el6.x86_64
--> Processing Dependency: libvdpau.so.1()(64bit) for package: gstreamer-plugins-bad-0.10.19-9.el6.x86_64
--> Processing Dependency: libschroedinger-1.0.so.0()(64bit) for package: gstreamer-plugins-bad-0.10.19-9.el6.x86_64
--> Processing Dependency: libmusicbrainz.so.4()(64bit) for package: gstreamer-plugins-bad-0.10.19-9.el6.x86_64
--> Processing Dependency: libmplex2-2.0.so.0()(64bit) for package: gstreamer-plugins-bad-0.10.19-9.el6.x86_64
--> Processing Dependency: libmodplug.so.1()(64bit) for package: gstreamer-plugins-bad-0.10.19-9.el6.x86_64
--> Processing Dependency: libmms.so.0()(64bit) for package: gstreamer-plugins-bad-0.10.19-9.el6.x86_64
--> Processing Dependency: libmjpegutils-2.0.so.0()(64bit) for package: gstreamer-plugins-bad-0.10.19-9.el6.x86_64
--> Processing Dependency: liblrdf.so.2()(64bit) for package: gstreamer-plugins-bad-0.10.19-9.el6.x86_64
--> Processing Dependency: libkate.so.1()(64bit) for package: gstreamer-plugins-bad-0.10.19-9.el6.x86_64
--> Processing Dependency: libfaad.so.2()(64bit) for package: gstreamer-plugins-bad-0.10.19-9.el6.x86_64
--> Processing Dependency: libfaac.so.0()(64bit) for package: gstreamer-plugins-bad-0.10.19-9.el6.x86_64
--> Processing Dependency: libdvdnav.so.4()(64bit) for package: gstreamer-plugins-bad-0.10.19-9.el6.x86_64
--> Processing Dependency: libdirac_encoder.so.0()(64bit) for package: gstreamer-plugins-bad-0.10.19-9.el6.x86_64
--> Processing Dependency: libdirac_decoder.so.0()(64bit) for package: gstreamer-plugins-bad-0.10.19-9.el6.x86_64
--> Processing Dependency: libdca.so.0()(64bit) for package: gstreamer-plugins-bad-0.10.19-9.el6.x86_64
--> Processing Dependency: libdc1394.so.22()(64bit) for package: gstreamer-plugins-bad-0.10.19-9.el6.x86_64
--> Processing Dependency: libcdaudio.so.1()(64bit) for package: gstreamer-plugins-bad-0.10.19-9.el6.x86_64
--> Processing Dependency: libass.so.4()(64bit) for package: gstreamer-plugins-bad-0.10.19-9.el6.x86_64
--> Processing Dependency: libamrwb.so.3()(64bit) for package: gstreamer-plugins-bad-0.10.19-9.el6.x86_64
---> Package gstreamer-plugins-bad-free.x86_64 0:0.10.19-2.el6 will be obsoleted
---> Package httpd.x86_64 0:2.2.15-28.el6.centos will be updated
---> Package httpd.x86_64 0:2.2.15-29.el6.centos will be an update
---> Package httpd-manual.noarch 0:2.2.15-28.el6.centos will be updated
---> Package httpd-manual.noarch 0:2.2.15-29.el6.centos will be an update
---> Package httpd-tools.x86_64 0:2.2.15-28.el6.centos will be updated
---> Package httpd-tools.x86_64 0:2.2.15-29.el6.centos will be an update
---> Package initscripts.x86_64 0:9.03.38-1.el6.centos.1 will be updated
---> Package initscripts.x86_64 0:9.03.38-1.el6.centos.2 will be an update
---> Package kernel.x86_64 0:2.6.32-358.18.1.el6 will be installed
---> Package kernel-devel.x86_64 0:2.6.32-358.18.1.el6 will be installed
---> Package kernel-firmware.noarch 0:2.6.32-358.11.1.el6 will be updated
---> Package kernel-firmware.noarch 0:2.6.32-358.18.1.el6 will be an update
---> Package kernel-headers.x86_64 0:2.6.32-358.11.1.el6 will be updated
---> Package kernel-headers.x86_64 0:2.6.32-358.18.1.el6 will be an update
---> Package kpartx.x86_64 0:0.4.9-64.el6 will be updated
---> Package kpartx.x86_64 0:0.4.9-64.el6_4.2 will be an update
---> Package libtevent.x86_64 0:0.9.17-1.el6 will be updated
---> Package libtevent.x86_64 0:0.9.18-1.el6_4 will be an update
---> Package mod_ssl.x86_64 1:2.2.15-28.el6.centos will be updated
---> Package mod_ssl.x86_64 1:2.2.15-29.el6.centos will be an update
---> Package neon.x86_64 0:0.29.3-2.el6 will be updated
---> Package neon.x86_64 0:0.29.3-3.el6_4 will be an update
---> Package net-snmp.x86_64 1:5.5-44.el6_4.2 will be updated
---> Package net-snmp.x86_64 1:5.5-44.el6_4.4 will be an update
---> Package net-snmp-libs.x86_64 1:5.5-44.el6_4.2 will be updated
---> Package net-snmp-libs.x86_64 1:5.5-44.el6_4.4 will be an update
---> Package net-snmp-utils.x86_64 1:5.5-44.el6_4.2 will be updated
---> Package net-snmp-utils.x86_64 1:5.5-44.el6_4.4 will be an update
---> Package nspr.x86_64 0:4.9.2-1.el6 will be updated
---> Package nspr.x86_64 0:4.9.5-2.el6_4 will be an update
---> Package nss.x86_64 0:3.14.0.0-12.el6 will be updated
---> Package nss.x86_64 0:3.14.3-4.el6_4 will be an update
---> Package nss-softokn.x86_64 0:3.12.9-11.el6 will be updated
---> Package nss-softokn.x86_64 0:3.14.3-3.el6_4 will be an update
---> Package nss-softokn-freebl.x86_64 0:3.12.9-11.el6 will be updated
---> Package nss-softokn-freebl.x86_64 0:3.14.3-3.el6_4 will be an update
---> Package nss-sysinit.x86_64 0:3.14.0.0-12.el6 will be updated
---> Package nss-sysinit.x86_64 0:3.14.3-4.el6_4 will be an update
---> Package nss-tools.x86_64 0:3.14.0.0-12.el6 will be updated
---> Package nss-tools.x86_64 0:3.14.3-4.el6_4 will be an update
---> Package nss-util.x86_64 0:3.14.0.0-2.el6 will be updated
---> Package nss-util.x86_64 0:3.14.3-3.el6_4 will be an update
---> Package openswan.x86_64 0:2.6.32-20.el6_4 will be updated
---> Package openswan.x86_64 0:2.6.32-21.el6_4 will be an update
---> Package perf.x86_64 0:2.6.32-358.11.1.el6 will be updated
---> Package perf.x86_64 0:2.6.32-358.18.1.el6 will be an update
---> Package php-pecl-mongo.x86_64 0:1.4.1-1.el6.remi.1 will be updated
---> Package php-pecl-mongo.x86_64 0:1.4.2-1.el6 will be an update
--> Processing Dependency: php(zend-abi) = 20090626 for package: php-pecl-mongo-1.4.2-1.el6.x86_64
--> Processing Dependency: php(api) = 20090626 for package: php-pecl-mongo-1.4.2-1.el6.x86_64
---> Package prelink.x86_64 0:0.4.6-3.el6 will be updated
---> Package prelink.x86_64 0:0.4.6-3.1.el6_4 will be an update
---> Package sos.noarch 0:2.2-38.el6.centos will be updated
---> Package sos.noarch 0:2.2-38.el6.centos.2 will be an update
---> Package xorg-x11-drv-mga.x86_64 0:1.6.1-7.el6 will be updated
---> Package xorg-x11-drv-mga.x86_64 0:1.6.1-8.el6_4 will be an update
--> Running transaction check
---> Package firefox.x86_64 0:17.0.8-1.el6.centos will be an update
--> Processing Dependency: xulrunner >= 17.0.8 for package: firefox-17.0.8-1.el6.centos.x86_64
---> Package gstreamer-plugins-bad.x86_64 0:0.10.19-9.el6 will be obsoleting
--> Processing Dependency: libmodplug.so.1()(64bit) for package: gstreamer-plugins-bad-0.10.19-9.el6.x86_64
---> Package libamrwb.x86_64 0:7.0.0.4-3.el6 will be installed
---> Package libass.x86_64 0:0.9.11-1.el6 will be installed
--> Processing Dependency: libenca.so.0()(64bit) for package: libass-0.9.11-1.el6.x86_64
---> Package libcdaudio.x86_64 0:0.99.12p2-11.el6 will be installed
---> Package libdc1394.x86_64 0:2.1.2-3.4.el6 will be installed
---> Package libdca0.x86_64 0:0.0.5-4.el6 will be installed
---> Package libdirac.x86_64 0:1.0.2-4.el6 will be installed
---> Package libdvdnav.x86_64 0:4.1.4-0.1.svn1184.el6 will be installed
---> Package libfaac.x86_64 0:1.28-3.el6 will be installed
---> Package libfaad2.x86_64 1:2.7-18.el6 will be installed
---> Package libkate.x86_64 0:0.3.7-1.el6 will be installed
---> Package liblrdf.x86_64 0:0.5.0-2.el6 will be installed
--> Processing Dependency: ladspa for package: liblrdf-0.5.0-2.el6.x86_64
--> Processing Dependency: libraptor2.so.0()(64bit) for package: liblrdf-0.5.0-2.el6.x86_64
---> Package libmms.x86_64 0:0.6.2-4.el6 will be installed
---> Package libmusicbrainz.x86_64 0:2.1.5-11.1.el6 will be installed
---> Package libschroedinger.x86_64 0:1.0.10-3.el6 will be installed
---> Package libvdpau1.x86_64 0:0.4.1-4.el6 will be installed
---> Package libxvidcore.x86_64 0:1.3.2-1.el6 will be installed
---> Package mjpegtools.x86_64 1:2.0.0-22.el6 will be installed
--> Processing Dependency: libquicktime.so.0()(64bit) for package: 1:mjpegtools-2.0.0-22.el6.x86_64
---> Package php-pecl-mongo.x86_64 0:1.4.2-1.el6 will be an update
--> Processing Dependency: php(zend-abi) = 20090626 for package: php-pecl-mongo-1.4.2-1.el6.x86_64
--> Processing Dependency: php(api) = 20090626 for package: php-pecl-mongo-1.4.2-1.el6.x86_64
--> Running transaction check
---> Package firefox.x86_64 0:17.0.8-1.el6.centos will be an update
--> Processing Dependency: xulrunner >= 17.0.8 for package: firefox-17.0.8-1.el6.centos.x86_64
---> Package gstreamer-plugins-bad.x86_64 0:0.10.19-9.el6 will be obsoleting
--> Processing Dependency: libmodplug.so.1()(64bit) for package: gstreamer-plugins-bad-0.10.19-9.el6.x86_64
---> Package ladspa.x86_64 0:1.13-6.1.el6 will be installed
---> Package libenca.x86_64 0:1.13-3.el6 will be installed
---> Package libquicktime0.x86_64 0:1.2.4-31.el6 will be installed
---> Package libraptor2.x86_64 0:2.0.7-3.el6 will be installed
---> Package php-pecl-mongo.x86_64 0:1.4.2-1.el6 will be an update
--> Processing Dependency: php(zend-abi) = 20090626 for package: php-pecl-mongo-1.4.2-1.el6.x86_64
--> Processing Dependency: php(api) = 20090626 for package: php-pecl-mongo-1.4.2-1.el6.x86_64
--> Finished Dependency Resolution
Error: Package: php-pecl-mongo-1.4.2-1.el6.x86_64 (epel)
           Requires: php(api) = 20090626
           Installed: php-common-5.5.0-0.33.RC2.el6.remi.x86_64 (@remi-test)
               php(api) = 20121113-64
           Available: php-common-5.3.3-22.el6.x86_64 (base)
               php(api) = 20090626
           Available: php-common-5.3.3-23.el6_4.x86_64 (updates)
               php(api) = 20090626
Error: Package: gstreamer-plugins-bad-0.10.19-9.el6.x86_64 (linuxtech-release)
           Requires: libmodplug.so.1()(64bit)
Error: Package: php-pecl-mongo-1.4.2-1.el6.x86_64 (epel)
           Requires: php(zend-abi) = 20090626
           Installed: php-common-5.5.0-0.33.RC2.el6.remi.x86_64 (@remi-test)
               php(zend-abi) = 20121212-64
           Available: php-common-5.3.3-22.el6.x86_64 (base)
               php(zend-abi) = 20090626
           Available: php-common-5.3.3-23.el6_4.x86_64 (updates)
               php(zend-abi) = 20090626
Error: Package: firefox-17.0.8-1.el6.centos.x86_64 (updates)
           Requires: xulrunner >= 17.0.8
           Installed: xulrunner-17.0.6-2.el6.centos.x86_64 (@updates)
               xulrunner = 17.0.6-2.el6.centos
           Available: xulrunner-1.9.2.4-0.10.el6.x86_64 (atrpms-stable)
               xulrunner = 1.9.2.4-0.10.el6
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

I'm fairly new to Centos but I've been using GNU/Linux, Ubuntu for two years. Thanks for looking.

share|improve this question
1  
How many different repositories are you using? Also, this doesn't look like a server. –  dawud Sep 4 '13 at 12:20
    
Looks like you have an extra repo or two. Can you run yum repolist ? –  ewwhite Sep 4 '13 at 12:20
    
thanks, its a minimum install of Centos ,but i hope to upgrade to a full server eventually, here's the output for repolist: –  pmac95 Sep 4 '13 at 12:43

1 Answer 1

You've got PHP 5.5 installed from Remi Collet's repo. PHP modules require PHP of same version, because there is binding on binary level.

php-pecl-mongo package from update requires version 5.3, which is available from other/original repos, and you've got 5.5.

try

yum update --enablerepo=remi

If this doesn't work, install required remi-release package: http://blog.famillecollet.com/pages/Config-en

If this doesn't help, then you can either ignore update with --skip-broken or search for mongo module package from other sources.

share|improve this answer
    
thanks GioMac, it doesnt work but i'm looking intothe leads you gave, will get back with more info –  pmac95 Sep 4 '13 at 12:46
    
you need module for 5.5. According to experience, Remi's 5.5 PHP is problematic, if PHP 5.3 is ok for you - uninstall remi packages and install php 5.3 packages from original repos. Also, remove rpmforge. –  GioMac Sep 4 '13 at 12:48
    
serverfault.com/questions/530513/… –  GioMac Sep 4 '13 at 12:49

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.