Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I am under the impression that 2 of the 6 GB on a ESXi 5 host are not used.

This is a single host with a free licence.

When I assign resources to the VMs there is only 4GB available, and under "resource alloction" in the vSpehere GuI client there is only 3736 MB total capacity RAM dispalayd.

But in configuration - memory I can see correctly the 6 GB RAM.

At first the Host had only 4 GB and I upgrade to 6 later.

I tried to enter more here in the yellow box as suggested, but an error message shows the upper limit


EDIT: Now this is solved, I try to explain what was the mistake:

  • It is possible to use all the amount. For example I can create another VM and it will have all the not yet reserved memory avalable for reservation
  • The sum of 6GB can be divided into several reservations. If a part is reserverd, in the next reservation only th remainder is shown as availble, and not the total amount. If 2 GB of 6GB total are reservdr, it will show 4GB available for another reservation.

EDIT: Later I understood why: When in the other resource pool there is 2GB reservered, obviously only remaining 4GB can be entered here to reserve.

enter image description here

Here you can see that it shows 6 GB total:

enter image description here

"Resource allocation" has also only 4GB total

EDIT: now after solving the issues, this is what remains unsolved, hot to interpret the memory "Toatal capacity" and "available capacity" and why is there sometimes not shown all the capacity? but after creating an additional vm with more ram, these values also increased, so no need to worry anymore.

enter image description here

I can see 6GB in the host summary:

enter image description here

share|improve this question

2 Answers 2

up vote 1 down vote accepted

I am under the impression that 2 of the 6 GB on a ESXi 5 host are not used.

You're under the wrong impression, ESXi will use as much memory as you have so long as it's needed. Perhaps if you showed us some screenshots we could help clarify your misunderstanding.

share|improve this answer
    
I will keep adding screnshots. which screens of vCenter GUI do you think could help? –  Alojz Janez Sep 4 '13 at 14:52
    
Your answer is correct, it is using the 6GB. I will explin in the question where my mistake was. –  Alojz Janez Sep 4 '13 at 15:24
    
No problem - that said why are you even going near resource pools - they're there for a reason, it's very easy to get things very wrong by using them, try to avoid if possible, ok. –  Chopper3 Sep 4 '13 at 15:26
    
I did not add a resource pool, I only did this to experiment if I can find out about the memory, I did not actually add one,. But isnt there always one resource pool already when you install a free ESXi single host? It is always putting new VMs into a "resource pool" so there must be at least one? –  Alojz Janez Sep 4 '13 at 15:37
1  
there's no need to have them, they really can lead to all sorts of imbalanced setups - I'm quite well qualified in vsphere but even I avoid them unless there's a great reason. Just take them out of the RP, it's as simple as that. –  Chopper3 Sep 4 '13 at 15:43

Umm.. what happens if you uncheck the box for "unlimited" and move that slider around - or create a new resource pool? The fact that you upgraded from 4 to 6GB of RAM points back to that original 4GB there.

However, you'll notice that it is grayed out because it's not being limited to that 4GB but is able to expand that reservation on that resource pool to the max available (thus the "unlimited" check box) to ESX (the 5861.0MB listed).

What are you hoping to accomplish with resource pools? If you only have 6GB and you want to use all 6GB, there is really no reason to setup resource pools. You also really don't have enough resources with 6GB to really make use or resource pools so I'm trying to get a little more detail on why you want to set these up.

share|improve this answer
    
I updated the picture: I tried what you suggested, the reservation slider can not go further than 315. I tried to edit the limit value in the yellow box but but it won't let me enter more than 4GB. See the error message in the new picture. –  Alojz Janez Sep 4 '13 at 15:12
    
I would rather not use resource pools, I was only trying to proove that only 4GB are available. But isnt there always one resource pool? Or can I get rid of them completely? If there is one resource pool always, shouldnt it show 6GB? How can I then teach it to use all 6GB –  Alojz Janez Sep 4 '13 at 15:13
    
OK, it is solved, I am updating the question to explain everythng and maybe it will help someone –  Alojz Janez Sep 4 '13 at 15:25

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.