Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I hope someone can help me solve this mystery. I have a small linux box which is configured as a transparent proxy on my network. I'm trying to run a script at startup that does a continuous ping to one of my servers. If the server responds I run my command. Here is the script:

while true 
do     
    ping -s 1 -c 1 -W 1 $serverIP >/dev/null                         
    sleep 3
done 

I have a startup script that runs after the other services have started. I run the above script from that. Now comes the weird part...When my ping script is run by my startup script all https requests time out. Normal http requests are just fine. If I kill the script and run it manually in my terminal window the ping works and https requests work. I don't see how this ping script is making https requests time out. Can you shed some light?

Thanks!

EV

share|improve this question
1  
Have you tried tcpdump and/or ssldump? –  dawud Sep 5 '13 at 8:00
    
You're really caching https in your proxy? –  ott-- Sep 5 '13 at 9:20
    
@dawud no, I haven't tried those...good suggestion. I'll see if I can figure that out. –  user548971 Sep 5 '13 at 9:49
    
@ott, no, I'm not caching https. I'm just passing it through. It is essentially acting as a router. –  user548971 Sep 5 '13 at 9:49
    
What happens if you use only the -c 1 option? –  Dennis Williamson Sep 5 '13 at 10:00

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.