Sign up ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Im trying to redirect to my firewall, which is 192.168.x.x.

When using proxypass, i get this errors in my log, and a 404 in my client:

[error] [client x.x.x.x] File does not exist: /var/www/fw

This is my vhost file:

<VirtualHost *:80>
ProxyPreserveHost On
ProxyPass /fw http://192.168.x.x
ProxyPassReverse /fw http://192.168.x.x

Any ideas?

(Apache/2.2.22 (Debian))

apachectl -S

 wildcard NameVirtualHosts and _default_ servers:
*:80                   is a NameVirtualHost
         default server (/etc/apache2/sites-enabled/www:4)
         port 80 namevhost (/etc/apache2/sites-enabled/www:4)
         port 80 namevhost (/etc/apache2/sites-enabled/www:10)
         port 80 namevhost (/etc/apache2/sites-enabled/www:16)
         port 80 namevhost (/etc/apache2/sites-enabled/www:24)
         port 80 namevhost (/etc/apache2/sites-enabled/www:30)
Syntax OK
share|improve this question

put on hold as off-topic by Jenny D, Ward, womble 8 hours ago

  • This question does not appear to be about server, networking, or related infrastructure administration within the scope defined in the help center.
If this question can be reworded to fit the rules in the help center, please edit the question.

can you please add the output of apachectl -S? – dawud Sep 7 '13 at 13:03
I'm voting to close this question as off-topic because the config is obviously wrong based on what little information is given, but the user is no longer around to give the information necessary to get it right. – Jenny D yesterday

2 Answers 2

normally ProxyPass should have an URL part lile / in this case.

Can you try the following?

ProxyPass /fw http://192.168.x.x/
ProxyPassReverse /fw http://192.168.x.x/
share|improve this answer

Seems like a silly question but is the module enabled? I don't believe it's enabled by default, nor installed for that matter.

share|improve this answer
LoadModule proxy_module modules/ LoadModule proxy_http_module modules/ – Henk Sep 7 '13 at 14:14

Not the answer you're looking for? Browse other questions tagged or ask your own question.