Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm securing a server and closing all the ports that are not used, but i can't close the syslogd port, even worse I cannot find where the syslogd is called.

This is what sockstat shows me:

USER    COMMAND PID FD  PROTO   LOCAL ADDRESS   FOREIGN ADDRESS
root    syslogd 746 7   udp4    *:514           *:*
root    sshd    628 4   tcp4    *:22            *:* 

and the rc.conf:

defaultrouter="192.168.15.1"
ifconfig_dc0="inet 192.168.15.107 netmask 255.255.255.0"
# hostname
hostname="xxxxx"
sshd_enable="YES"
# Set dumpdev to "AUTO" to enable crash dumps, "NO" to disable
dumpdev="AUTO"

I only need the sshd service.

share|improve this question

1 Answer 1

up vote 3 down vote accepted

You can disable remote logs adding the following line to the file '/etc/rc.conf'.

syslogd_flags="-s"

Or use this one to close the network sockets:

syslogd_flags="-ss"

After added the syslogd_flags you can use this command to restart the service:

service syslogd restart
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.