Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I use sernet-samba package (version 4.0.9-6) on Debian 7. Samba configured as additional AD controller. Samba process infinitely writes something to disk and makes high I/O load:

Total DISK READ:       0.00 B/s | Total DISK WRITE:     204.37 K/s
TID  PRIO  USER     DISK READ  DISK WRITE  SWAPIN     IO>    COMMAND                                                                
140 be/3 root        0.00 B/s    0.00 B/s  0.00 % 58.45 % [jbd2/vda1-8]
4081 be/4 root        0.00 B/s  110.05 K/s  0.00 %  3.49 % samba -D

It is not logs, I think, because they relatively small.

/etc/samba/smb.conf

# Global parameters
[global]
    workgroup = DALSTRAZH
    realm = dalstrazh.localnet
    netbios name = SAMBA4K76
    server role = active directory domain controller
        server services = rpc, nbt, wrepl, ldap, cldap, kdc, drepl, winbind, ntp_signd, kcc, dnsupdate, smb
        dcerpc endpoint servers = +winreg +srvsvc
    log level = 1
[netlogon]
    path = /var/lib/samba/sysvol/dalstrazh.localnet/scripts
    read only = No

[sysvol]
    path = /var/lib/samba/sysvol
    read only = No

lsof -p 4081 - http://pastebin.com/BZVuNyA2

mount

sysfs on /sys type sysfs (rw,nosuid,nodev,noexec,relatime)
proc on /proc type proc (rw,nosuid,nodev,noexec,relatime)
udev on /dev type devtmpfs (rw,relatime,size=10240k,nr_inodes=217587,mode=755)
devpts on /dev/pts type devpts (rw,nosuid,noexec,relatime,gid=5,mode=620,ptmxmode=000)
tmpfs on /run type tmpfs (rw,nosuid,noexec,relatime,size=313936k,mode=755)
/dev/disk/by-uuid/b7ff5fd8-dc08-4b00-be23-6c9c91eecec5 on / type ext4 (rw,noatime,errors=remount-ro,user_xattr,commit=60,barrier=1,data=writeback)
tmpfs on /run/lock type tmpfs (rw,nosuid,nodev,noexec,relatime,size=5120k)
tmpfs on /run/shm type tmpfs (rw,nosuid,nodev,noexec,relatime,size=909660k)
rpc_pipefs on /var/lib/nfs/rpc_pipefs type rpc_pipefs (rw,relatime)

data=journal and data=ordered takes no effect.

On second server (with same configuration) i/o seems normal.

How to find file which causes this problem, and how to fix it?

share|improve this question
add comment

1 Answer 1

Disabling the filesystem journal helps, but I think it is a bad idea. Mounting with the barrier=0 option helps also.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.