Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.
cat /etc/sysconfig/network-scripts/ifcfg-eth0
DEVICE="eth0"
BOOTPROTO="none"
HWADDR="00:0C:29:02:8C:1A"
ONBOOT="yes"
GATEWAY="192.168.2.1"
NETMASK="255.255.255.0"
IPADDR="192.168.2.4"
TYPE="Ethernet"

I get the following:

yum update
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
Could not retrieve mirrorlist http://mirrorlist.centos.org/?release=6&arch=x86_64&repo=os error was
14: PYCURL ERROR 7 - "Failed to connect to 2a02:2498:1:3d:5054:ff:fed3:e91a: Network is unreachable"
Error: Cannot find a valid baseurl for repo: base

BROADCAST is depreciated I read on the CentOS site. What am I missing?

share|improve this question
    
How is your interface actually currently configured? –  Michael Hampton Sep 18 '13 at 1:39
1  
It's choosing to use IPv6 rather than IPv4. Either configure IPv6 correctly or disable it. –  200_success Sep 18 '13 at 1:42
add comment

2 Answers

For whatever reason, you have an IPv6 address other than the link-local address, but it doesn't have a route to where that server is (most likely because it doesn't have a default route).

IPv6 addresses can become configured a number of different ways. For instance, you might be running a teredo daemon (eg. miredo), you may have set up a script that sets an IPv6 address somewhere else, or you might have something announcing routes on one of the network segments this computer is attached to. Either way, use ip -6 addr to determine which interface it is that has this address, and use that to infer where it is coming from.

Either fix your IPv6 routing, or disable it entirely. How to fix it depends very much on what the specific problem is; in any case, the configuration is very strange (teredo configurations should basically never experience this problem, nor should RA-configured addresses). You can prevent the host from loading an IPv6 stack by blacklisting the ipv6 module, though really everyone should try to support dual-stack.

This would make the reasoning behind the error more clear; as you've mentioned in your answer it is also possible that both ipv4 and ipv6 have failed.

It's also possible that you are using ipv6 through a tunnel, and your IPv4 routing is broken.

share|improve this answer
add comment
up vote 5 down vote accepted

Fixed. The router/firewall or Gateway was 192.168.2.253.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.