Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a brand new install of Windows Server 2012 with IIS 8 on a colocated box. I moved the InetPub folder to D:\ using the script here.

I set a domain to point to the server.

I added a new website with the machine's IP address and the domain as the host name

When I go to that web site from the local server (using the domain name) I get the default web site, not the new one with that host name configured. Btw, DNS propagation is done.

However, when I browse to that domain from my dev machine, I get a 404 error. If I explicitly go to the default page on my new site (index.html) it displays.

So two issues here (are they related?):

  1. Local machine seems hared wired to go to the stock default web site (i.e No IP address or host name assigned.)
  2. The default document feature is not working on new web site. I verified it is enabled.

I will also post the default document issue separately (with its own Title) in case it is not in any way related.


share|improve this question
What happens if you stop the default website? Sounds like the bindings are in need of adjustment. – DanBig Sep 11 '13 at 17:38
Then I get a 404 error. My first suspect was also the bindings, but they are correct to best of my knowledge. And they work external from the server. – Brad Mathews Sep 11 '13 at 18:13
I got the default document problem fixed. See link for my answer. – Brad Mathews Sep 11 '13 at 18:21
If I change the IP address of the new website to All Unassigned rather than the IP address of the server, it works. – Brad Mathews Sep 11 '13 at 18:34
It has to do with local DNS resolving to different IP than in IIS bindings perhaps – Brock Hensley Sep 12 '13 at 0:50

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.