Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've applied the new KB973869 hotfix multiple times on my x64 2003 and XP systems and Windows Update keeps saying it needs to be re-applied. What's going on?

share|improve this question

2 Answers 2

up vote 1 down vote accepted

Bug confirmed: WSUS Blog

If you are running WSUS and find that that your server never syncs, check for failed downloads (by selecting "file status" in the updates view), and decline the associated updates. There is a corrupted Exchange Antispam update out there.

share|improve this answer

I think there's a bug in the hotfix's detection routine that determines whether it needs to be applied or not. The hotfix article describes a single ocx file being updated depending on your OS and service branch. For Server 2003, it's wdhtmled.ocx being updated to version 6.1.0.9247.

Doing a filesystem search on my root partition reveals 5 copies of that file. 2 of them are just the patched versions from the downloaded hotfix. The other three are in

%SystemRoot%\ServicePackFiles\i386
%SystemRoot%\system32\dllcache
%SystemRoot%\$hf_mig$\KB973869\SP2QFE\wow

The one in ServicePackFiles is the only one that is unpatched and I don't think it's supposed to be patched since that folder is just an expanded cached copy of SP2 that was applied to the system.

In any case, I don't think there's anything to worry about. The only still vulnerable file isn't the one used by Windows. I'm guessing Microsoft will release a fixed version of the patch soon enough and the nagging will go away.

share|improve this answer
    
Nice, patches for their patches :-) –  Kyle Brandt Aug 13 '09 at 16:09

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.