Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I created a sub-interface on a RHEL box, eth0:1, and copied the eth0 config and changed all the settings to reflect eth0:1 and the IP address. However, when I issue ifup eth0:1 I receive this error:

[root@server-1 ~]# ifup eth0:1
Error, some other host already uses address 192.168.0.2.

[root@server-1 ~]# ping -c 1 192.168.0.2
PING 192.168.0.2 (192.168.0.2) 56(84) bytes of data.

--- 192.168.0.2 ping statistics ---
1 packets transmitted, 0 received, 100% packet loss, time 10000ms

However, when I issue: ifconfig eth0:1 192.168.0.2 up the command works and no errors. I would use the later command, but when I use it, it interferes with my primary, eth0, interface, and messes up the routing of my DNS traffic because its on the same subnet as the sub-interface eth0:1. I will make another post about the DNS issue.

These are the configs of the interfaces

[root@server-1 network-scripts]# cat ifcfg-eth0
DEVICE="eth0"
BOOTPROTO="static"
HWADDR="00:50:56:AF:0C:06"
IPADDR="192.168.0.1"
IPV6INIT="yes"
NETMASK="255.255.255.0"
ONBOOT="yes"
TYPE="Ethernet"
DNS1="192.168.2.10"
DNS2="192.168.3.10"

[root@server-1 network-scripts]# cat ifcfg-eth0:1
DEVICE="eth0:1"
BOOTPROTO="static"
HWADDR="00:50:56:AF:0C:06"
IPADDR="192.168.0.2"
IPV6INIT="yes"
NETMASK="255.255.255.0"
ONBOOT="no"
TYPE="Ethernet"
DNS1="192.168.2.10"
DNS2="192.168.3.10"

ip addr show

[root@server-1 network-scripts]# ip addr show
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 16436 qdisc noqueue state UNKNOWN
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP qlen 1000
    link/ether 00:50:56:AF:0c:06 brd ff:ff:ff:ff:ff:ff
    inet 192.168.0.1/24 brd 192.168.0..255 scope global eth0
    inet 192.168.2.1/30 brd 192.168.2.3 scope global eth0:2
    inet 192.168.2.5/30 brd 192.168.2.7 scope global eth0:3
    inet6 fe80::250:56ff:fe97:c06/64 scope link
       valid_lft forever preferred_lft forever
share|improve this question
    
Can you post the contents of the ifcfg-eth0:1 file? –  John Sep 12 '13 at 14:43
    
Configs posted. –  Pred Sep 12 '13 at 15:01
    
Did you remove/change MAC addresses (HWADDR)? –  dsmsk80 Sep 12 '13 at 15:07
    
No, I copied what is in the config files. When I created the configs, i just did a `cp ifcfg-eth0 ifcfg-eth0:1 then edited the name and IP address. –  Pred Sep 12 '13 at 15:08
    
Please send output of "ip addr show" from that host. You can have multiple IP addresses on single interface without any sub-interfaces. –  dsmsk80 Sep 12 '13 at 15:09

1 Answer 1

This message is generated either by /etc/sysconfig/network-scripts/ifup-eth or /etc/sysconfig/network-scripts/ifup-aliases which process ifcfg-ethX configuration files to configure network interfaces.

When you check the scripts more carefully you will find out that this error appears after arping command which is trying to find out if the IP addresses specified in ifcfg-ethX files are unique in the network.

The scripts try to avoid of duplicate configurations in the network. Ifconfig doesn't care, it just add IP address to the interface. Check your configuration files twice as there may be some IP address twice.

Finally, it's worth to mention that you can put ARPCHECK=no directive to ifcfg-ethX file to disable this check.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.