Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

This subject is a little bit outside of my experience, but we are trying to upgrade our server. We have a new machine, but are using the same versions of the servers on it (MS Server 2003, and SQL Server 2005).

On our first attempt, we had problems with the new server randomly dropping the user connections, so we reverted to the old server. The boss thinks he has that worked out, but we had another problem concerniong moving the databases that is bugging us.

To move the databases over, we detached them from the old server, and copied the data files and the log files to the new server and reattached them there. Everything seemed fine, but somehow upon a reboot, they became snapshots.

That was 2 weeks ago, and we are gearing up to try the switch again.

We would like to know what causes the databases to convert to a snapshot? It's my understanding that a snapshot is a read-only database. Checking the properties for the databases shows the database read-only state as being false. I'm assuming that is the default value, and must be manually changed by the administrator? Every thing seems to be going ok this time, but we still have no idea how the databases got converted to snapshots last time and would like some tips as to what to look for.

Thanks.

Marshall

share|improve this question
add comment

3 Answers 3

It seems the problem was related to permissions. We were moving the DB's from one domain to another. The first time we moved them, we did not bother with permissions, as we just wanted to see if they would attach properly. They did, but turned into snapshots when we rebooted the server.

The last time we moved the DB's, we removed all users from the old domain and added users from the new domain, which seemed to prevent the problem.

Thanks for the help all.

Marshall

share|improve this answer
add comment

I've got no idea how that could happen. You can't have a snapshot without having a base database which the snapshot is built on.

My guess would be that it was a bug with SSMS and that the databases were actually writeable if you tried to.

share|improve this answer
    
As far as I could tell, they were writable. It may be a permissions issue. New domain and all that comes with that headache. We are a 2 man shop, and neither of us, though knowledgable, are experts in the field of networking. –  Marshall Aug 14 '09 at 16:32
    
It the database was writeable it definetly wasn't a snapshot as snapshots are read only. By guess would be that you found a bug in SSMS. –  mrdenny Aug 14 '09 at 22:32
add comment

Can I ask what created the DB's to begin with? Was there an install process that automatically created them? If so you may want to try running that install against the new server then restore over the newly created DB with a current backup. I am no SQL Admin but have run into issues when just copying MDFs/LDFs over and attaching them.

share|improve this answer
    
I am not sure how or what created the DB's as the existed when I started work here. But we are moving from SQL 2005 Express to SQL 2005. I think we discovered the issue here. See my answer below. –  Marshall Sep 10 '09 at 18:22
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.