Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have some script in /etc/init.d that normally run when I restart my debian6 box. But some of these scripts are not executed at startup anymore, eg:

-rwxr-xr-x  1 root root   307 Aug  3 10:25 my-tomcat-starter

I have just changed the hostname (/etc/hostname) and updated password for my user and the root user. Can this have any effect?

I have looked in /var/log/syslog but there are no errors. I have tried:

root@machine:/etc/init.d# update-rc.d my-tomcat-starter defaults

But when I do:

ls /etc/rc?.d

It does not show up in the list. I have also tried:

root@machine:/etc/init.d# find /etc -iname 'my-tomcat-starter'
/etc/init.d/my-tomcat-starter
share|improve this question
    
So, is it listed in any runlevel to start??? (find /etc -iname 'my-tomcat-*') –  Marki Sep 12 '13 at 18:47
    
/etc/init.d is just the directory where the init scripts reside, it doesn't mean that any of them actually get executed. Only if the scripts are symlinked in /etc/rc.[0-6] is the service started/stopped at the relevant runlevel. I suggest man update-rc.d. –  Sammitch Sep 12 '13 at 22:38

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.