Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Trying to install MySQL (for WordPress) on a CentOS 6.4 /64 bit server.

I have installed the mysql-server-5.1.69-1.el6_4.x86_64 package and executed the following commands:

# chkconfig mysqld on
# service mysqld start
# /usr/bin/mysqladmin -u root password 'xxxxx'
# /usr/bin/mysql_secure_installation

Then I've noticed that mysqld_safe process is listening at 0.0.0.0 and decided to change that - so that my WordPress installation only uses domain sockets (or unix pipes? not sure about the correct term).

So I've modified the /etc/my.cnf to:

[mysqld]
datadir=/var/lib/mysql
socket=/var/lib/mysql/mysql.sock
user=mysql
# Disabling symbolic-links is recommended to prevent assorted security risks
symbolic-links=0
bind-address = localhost
skip-networking
enable-named-pipe

[mysqld_safe]
log-error=/var/log/mysqld.log
pid-file=/var/run/mysqld/mysqld.pid

But now MySQL refuses to start:

# service mysqld restart
Stopping mysqld:                                           [  OK  ]
MySQL Daemon failed to start.
Starting mysqld:                                           [FAILED]

The /var/log/mysqld.log contains:

 mysqld_safe Starting mysqld daemon with databases from /var/lib/mysql
  InnoDB: Initializing buffer pool, size = 8.0M
  InnoDB: Completed initialization of buffer pool
  InnoDB: Started; log sequence number 0 44233
 [ERROR] /usr/libexec/mysqld: unknown option '--enable-named-pipe'
 [ERROR] Aborting
  InnoDB: Starting shutdown...
  InnoDB: Shutdown completed; log sequence number 0 44233
 [Note] /usr/libexec/mysqld: Shutdown complete
 mysqld_safe mysqld from pid file /var/run/mysqld/mysqld.pid ended

I've searched Google and grepped /usr/share/mysql/*.cnf for that directive, but haven't found any hints there.

share|improve this question
add comment

1 Answer 1

up vote 3 down vote accepted

No hints?

[mysqld]
datadir=/var/lib/mysql
socket=/var/lib/mysql/mysql.sock
user=mysql
# Disabling symbolic-links is recommended to prevent assorted security risks
symbolic-links=0
bind-address = localhost
skip-networking
enable-named-pipe <-------------------

[mysqld_safe]
log-error=/var/log/mysqld.log
pid-file=/var/run/mysqld/mysqld.pid

According the online documentation for that version of MySQL:

--enable-named-pipe
Command-Line Format --enable-named-pipe
Option-File Format  enable-named-pipe
Platform Specific   windows  <--------------------

Enable support for named pipes. This option can be used only with the mysqld-nt and mysqld-debug servers that support named-pipe connections.

Remove that setting from your /etc/my.cnf and restart the process.

share|improve this answer
    
Thanks, didn't know mysqld-nt means Windows-only –  Alexander Farber Sep 13 '13 at 11:05
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.