Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I desperately need help.

I read an article on the echoditto blog ( and followed the recommendations for setting up dnsmasq on my mac using homebrew. Now I am having an issue I cannot resolve, and I need help, because it has totally crippled my development work.

Initially, after implementing dnsmaqs, I could not get my sites to load at all…but I was able to resolve that issue by changing the contents of my httpd-vhosts.conf file to the following:

#allow access to the Hosts directory where your sites are
<Directory "/Volumes/sites">
    Options Indexes FollowSymLinks MultiViews
    AllowOverride All
    #you could configure the following to only allow access from localhost
    Order allow,deny
    Allow from all

#get the server name from the Host: header
UseCanonicalName Off
VirtualDocumentRoot /Volumes/sites/%0/

Now, I can point my browser to and get the site to load.

However, using Joomla, I am having issues with mod_rewrite:

I can load the administrator backend without a problem by browsing to

I can load the home page of the site without any issues by browsing to

However, if I click on any link that would normally load a sub-page, such as I get either a 404 error or a 500 error and the following page contents:

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

I tried switching back to non-dynamic virtual hosting and it doesn't work anymore.

I also cannot access the sites by pointing the browser to http://localhost/

Please advise as soon as possible, because otherwise, I will have to go through a complete reinstall of my Mac and I cannot afford the downtime.

I have uploaded my httpd.conf file, httpd-vhosts.conf file and a sample .htaccess file to a gist:

Also, it may be of note that I tried reverting to the settings I had prior to installing dnsmasq so I could access the local sites using the URL scheme http://localhost/path/to/site but it no longer works, and I get a server configuration error.

share|improve this question
What was in the server error log? – Michael Hampton Sep 13 '13 at 14:55
Where should I look for the error log? – Ali Samii Sep 13 '13 at 15:25
@MichaelHampton [Fri Sep 13 17:32:35 2013] [error] [client] Request exceeded the limit of 10 internal redirects due to probable configuration error. Use 'LimitInternalRecursion' to increase the limit if necessary. Use 'LogLevel debug' to get a backtrace., referer: – Ali Samii Sep 13 '13 at 15:33
Well, now you know where the problem is. – Michael Hampton Sep 13 '13 at 15:34
[Fri Sep 13 17:35:29 2013] [debug] core.c(3112): [client] r->uri = /, referer: [Fri Sep 13 17:35:29 2013] [debug] core.c(3118): [client] redirected from r->uri = /, referer: [Fri Sep 13 17:35:29 2013] [debug] core.c(3118): [client] redirected from r->uri = /, referer: [Fri Sep 13 17:35:29 2013] [debug] core.c(3118): [client] redirected from r->uri = /, referer: – Ali Samii Sep 13 '13 at 15:36

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.