Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I'm trying to configure a DNS server for domain.com. I want to configure a wildcard DNS record to resolve any-subdomain.domain.com to a single IP address (172.16.1.3). In my DNS server I have the following records in my forward zone:

DNS Records

This somewhat works, except that when I run nslookup www.domain.com I get this response:

Server: winsrv.domain.com
Address: 172.16.1.2

Name: www.domain.com.domain.com
Address: 172.16.1.3

I believe the DNS server is thinking that the entire www.domain.com string is a subdomain of domain.com.

How do I get the DNS server to return the correct line: Name: www.domain.com

share|improve this question
    
Is domain.com in this example an Active Directory domain as well? And if so, is this DNS server an AD DNS server? –  MDMarra Sep 13 '13 at 19:25
    
Nope, no AD in use. Just a fresh Windows Server 2012 with updates and DNS installed. –  brack Sep 13 '13 at 19:32

1 Answer 1

up vote 1 down vote accepted

Here's what I suspect is happening but can't prove it on my own systems since I don't want to stick a wildcard record on my DNS servers.

This somewhat works, except that when I run nslookup www.domain.com I get this response:

Server: winsrv.domain.com
Address: 172.16.1.2

Name: www.domain.com.domain.com
Address: 172.16.1.3

This is because your nslookup query is technically an unqualified name.

You can test this by doing an nslookup www.domain.com. (note the trailing period/dot at the end that "qualifies" it) and see if the return is valid now.

EDIT: yeah this seams to be the case...because your wildcard entry is invalidating the normal NXDOMAIN response nslookup normally returns in this case. Since nslookup always appends the suffix if the lookup doesn't have the trailing period.

For instance, here's one on my computer:

> set debug=true
> www.yahoo.com
Server:  dc1.mdmarra.local
Address:  10.10.10.10

------------
Got answer:
    HEADER:
        opcode = QUERY, id = 2, rcode = NXDOMAIN
        header flags:  response, auth. answer, want recursion, recursion avail.
        questions = 1,  answers = 0,  authority records = 1,  additional = 0

    QUESTIONS:
        www.yahoo.com.mdmarra.local, type = A, class = IN
    AUTHORITY RECORDS:

Notice how it returned NXDOMAIN for www.yahoo.com.mdmarra.local. It will then go on to query just www.yahoo.com using forwarders. Since you have the wildcard entry it thinks your query is valid based on the wildcard.

share|improve this answer
    
Yep. Looks like you're right. Thanks for the information. –  brack Sep 13 '13 at 20:02
3  
Why is your DNS server named dc1.MDMARRA.local? –  joeqwerty Sep 13 '13 at 20:05
4  
Is MDMarra your alter ego? That would explain why I never see the two of you answer a question at the same time. –  joeqwerty Sep 13 '13 at 20:06
    
@joeqwerty :) just my way of obscuring the FQDN since I know how much he hates .local names. But I'll be happy to swap points with him. –  TheCleaner Sep 13 '13 at 20:18
    
He may forgive you for using .local in this instance ;) –  joeqwerty Sep 13 '13 at 20:20

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.